Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 142199 - [65cat] code fixes insert values twice
[65cat] code fixes insert values twice
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
:
: 142209 142241 142242 142281 142286 142297 142536 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 07:53 UTC by kawazu428
Modified: 2008-08-05 20:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
doubly inserted import statement (16.03 KB, image/jpeg)
2008-07-30 07:53 UTC, kawazu428
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kawazu428 2008-07-30 07:53:13 UTC
Quick-Fix, some parts of refactoring (noticed while doing refactor -> rename in a class) as well as "fix imports" seem
partly broken in recent 6.5 build. Behaviour: Choosing any of these options results in code being added twice, like

- two import statements for the same class (see picture attached),
- twice the class name in a row ("public class MyClassMyClass" in MyClass.java) 
- two "throws ...Exception" being added while using ALT+Enter -> "add throws clause for ...Exception".

Appeared this morning for the first time so seems related to current build.

Environment:

Product Version: NetBeans IDE Dev (Build 200807300201)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b15
System: Linux version 2.6.24-20-generic running on i386; UTF-8; de_DE (nb)
Userdir: /home/kr/.netbeans/dev-6.5
Comment 1 kawazu428 2008-07-30 07:53:55 UTC
Created attachment 66028 [details]
doubly inserted import statement
Comment 2 josin 2008-07-30 08:13:32 UTC
There is the same problem with generate dialog. It generates constructor, getter, setter ... all twice. But there are
two undo steps if it could help.


Product Version: NetBeans IDE Dev (Build 20080730045254)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Linux version 2.6.24-19-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/josin/.netbeans/dev
Comment 3 Jan Lahoda 2008-07-30 09:56:05 UTC
Caused by:
http://hg.netbeans.org/main/rev/c408b6a23fd0
should be fixed by:
http://hg.netbeans.org/main/rev/6d264ce84688
Comment 4 Jan Lahoda 2008-07-30 12:09:09 UTC
*** Issue 142209 has been marked as a duplicate of this issue. ***
Comment 5 Jan Lahoda 2008-07-30 14:17:23 UTC
*** Issue 142225 has been marked as a duplicate of this issue. ***
Comment 6 Petr Dvorak 2008-07-30 15:21:35 UTC
*** Issue 142241 has been marked as a duplicate of this issue. ***
Comment 7 Petr Dvorak 2008-07-30 17:59:57 UTC
*** Issue 142281 has been marked as a duplicate of this issue. ***
Comment 8 Petr Dvorak 2008-07-30 18:22:07 UTC
*** Issue 142286 has been marked as a duplicate of this issue. ***
Comment 9 Petr Dvorak 2008-07-30 19:16:05 UTC
*** Issue 142297 has been marked as a duplicate of this issue. ***
Comment 10 Petr Dvorak 2008-07-30 19:17:40 UTC
*** Issue 142297 has been marked as a duplicate of this issue. ***
Comment 11 Petr Dvorak 2008-07-30 19:20:09 UTC
*** Issue 142297 has been marked as a duplicate of this issue. ***
Comment 12 Petr Dvorak 2008-07-30 19:20:50 UTC
*** Issue 142297 has been marked as a duplicate of this issue. ***
Comment 13 Petr Dvorak 2008-07-30 19:21:11 UTC
*** Issue 142297 has been marked as a duplicate of this issue. ***
Comment 14 kawazu428 2008-07-31 07:19:32 UTC
fix verified in recent build as far as my use cases are concerned - thanks! :)

Product Version: NetBeans IDE Dev (Build 200807310201)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b15
System: Linux version 2.6.24-20-generic running on i386; UTF-8; de_DE (nb)
Userdir: /home/kr/.netbeans/dev-6.5
Comment 15 Jiri Prox 2008-07-31 08:07:19 UTC
*** Issue 142242 has been marked as a duplicate of this issue. ***
Comment 16 Jan Pokorsky 2008-08-01 11:01:11 UTC
*** Issue 142536 has been marked as a duplicate of this issue. ***
Comment 17 Jiri Kovalsky 2008-08-05 20:18:03 UTC
This issue was reported by NetCAT 6.5 participant.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo