Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 141470 - QuerySyntaxException during HQL query execution
QuerySyntaxException during HQL query execution
Status: RESOLVED DUPLICATE of bug 136996
Product: javaee
Classification: Unclassified
Component: Hibernate
6.x
All All
: P3 (vote)
: TBD
Assigned To: Vadiraj Deshpande
issues@javaee
:
: 141469 141472 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 05:52 UTC by Vadiraj Deshpande
Modified: 2008-07-28 23:02 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
project (19.00 KB, application/x-compressed)
2008-07-24 19:26 UTC, _ gowri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vadiraj Deshpande 2008-07-24 05:52:49 UTC
NetBeans 20080722

Steps to reproduce:
- Create a new project and a new hibernate cfg xml file with valid db data.
- Use Reverse Engg. wizard to generate POJOs and mappings..
- Open up HQL Editor and type a simple query like : 'from Address'.
- Click Run HQL Query button on the editor toolbar. QuerySyntaxException is produced.

Exception (first 6 lines)
org.hibernate.hql.ast.QuerySyntaxException: Address is not mapped [from Address]
   at org.hibernate.hql.ast.util.SessionFactoryHelper.requireClassPersister(SessionFactoryHelper.java:158)
   at org.hibernate.hql.ast.tree.FromElementFactory.addFromElement(FromElementFactory.java:87)
   at org.hibernate.hql.ast.tree.FromClause.addFromElement(FromClause.java:70)
   at org.hibernate.hql.ast.HqlSqlWalker.createFromElement(HqlSqlWalker.java:255)
   at org.hibernate.hql.antlr.HqlSqlBaseWalker.fromElementList(HqlSqlBaseWalker.java:2945)
Comment 1 Vadiraj Deshpande 2008-07-24 05:59:52 UTC
*** Issue 141472 has been marked as a duplicate of this issue. ***
Comment 2 Vadiraj Deshpande 2008-07-24 06:00:25 UTC
*** Issue 141469 has been marked as a duplicate of this issue. ***
Comment 3 _ gowri 2008-07-24 19:26:52 UTC
Created attachment 65579 [details]
project
Comment 4 _ gowri 2008-07-24 19:27:41 UTC
Vadiraj,

I have attached the project. Please take a look at it.
Comment 5 Vadiraj Deshpande 2008-07-28 23:02:50 UTC
This is same issue as 136996. HQL Editor needs to support Annotation Configuration. Marking this as duplicate.

*** This issue has been marked as a duplicate of 136996 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo