Bug 140241 - IDE freezes during deleting of project
IDE freezes during deleting of project
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Text
6.x
All All
: P3 (vote)
: 6.x
Assigned To: mslama
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-16 10:19 UTC by Jana Maleckova
Modified: 2009-03-27 15:00 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
threadDump (17.36 KB, text/plain)
2008-07-16 10:20 UTC, Jana Maleckova
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jana Maleckova 2008-07-16 10:19:32 UTC
Product Version: NetBeans IDE Dev (Build 200807101204)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b13
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)

Description:
============
I just did deleting of Java Desktop Application project (with resources) and IDE got frozen on 50%
I cannot reproduce it. I hope thread dump would help.
Comment 1 Jana Maleckova 2008-07-16 10:20:41 UTC
Created attachment 64678 [details]
threadDump
Comment 2 Lukas Hasik 2008-07-25 10:41:11 UTC
is it reproducible in latest builds? The TD doesn't help much :(
Comment 3 Jana Maleckova 2008-07-25 11:16:20 UTC
no, I haven't ran up against this problem since :( 
Comment 4 mslama 2008-07-28 19:55:24 UTC
Have you done anything before? AWT thread was loading form. Or was deletion only action you did and IDE was idle before?
Could you describe what you did before? We modified editor code recently to avoid such 'forever' locks. AWT thread is
waiting for document processing thread and DP thread should wake up AWT once it finishes its work. From thread dump I
cannot say why it did not. So I need way how to reproduce it to investigate why it happens.
Comment 5 Jana Maleckova 2008-07-29 15:49:18 UTC
as I remembered it correctly I had opened 3 JDA projects which I tried to delete one by one and this happened when the
last one was erased. 
I can confirm that view classes (form classes)are automatically opened when JDA project is created so they were opened
during deleting as well. I haven't close them before. 
Comment 6 mslama 2008-07-31 16:33:26 UTC
I will try to reproduce. As so far there is no way how to reproduce, we have only one occurrence and I am not able to
find out what happened from thread dump I am lowering to P3.
Comment 7 mslama 2009-03-27 15:00:37 UTC
Closing as WORKSFORME.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo