Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 139983 - Alt+Tab often leaves the menu in a selected state
Alt+Tab often leaves the menu in a selected state
Status: RESOLVED DUPLICATE of bug 73960
Product: platform
Classification: Unclassified
Component: -- Other --
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: issues@platform
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-15 06:41 UTC by bmorearty
Modified: 2008-12-22 13:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bmorearty 2008-07-15 06:41:10 UTC
This one's really starting to annoy me. :-)  Hitting Alt+Tab to switch apps and then switching back to NetBeans leaves 
the File menu highlighted.

1. Use Windows. This is an OS-specific bug.
2. Type Alt+Tab, a very common key combination to switch to another running application. 
3. Often when you do this the File menu will become highlighted (selected) and stays selected.
4. Alt+Tab back to NetBeans.
5. Don't notice that the File menu is highlighted.
6. Start typing into the editor.  Your keystrokes are interpreted as menu commands!  Yikes.

This happens about half the time I use Alt+Tab.  It seems to be slightly more reproducible if I hit Tab pretty quickly 
after hitting Alt.  (But certainly not more quickly than humanly possible; otherwise it wouldn't happen so much.)

The standard Windows behavior is:
- Typing Alt and then releasing the Alt key will highlight the first menu (typically File).  NetBeans does this 
correctly.
- But typing Alt+Tab should not highlight the menu.
Comment 1 Tomas Danek 2008-08-18 18:37:13 UTC
->Core/code. Really not sure where should this be fixed...Lukasi, please reassign.
Comment 2 Lukas Hasik 2008-08-22 12:46:27 UTC
Known Swing bug, not Netbeans specific...see info in duplicates. Anyway thanks for the report.

*** This issue has been marked as a duplicate of 73960 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo