Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 139839 - Possible deadlock when repainting the heap view (aka memory toolbar)
Possible deadlock when repainting the heap view (aka memory toolbar)
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-14 09:13 UTC by Petr Dvorak
Modified: 2008-12-22 13:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread Dump (18.47 KB, text/plain)
2008-07-14 09:14 UTC, Petr Dvorak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Dvorak 2008-07-14 09:13:41 UTC
Product Version: NetBeans IDE Dev (Build 200807101204)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b13
System: Linux version 2.6.24-19-generic running on i386; UTF-8; en_US (nb)

I started NB with a clean userdir and I opened a project. I worked for a minute or two, then I closed project and I
invoked open file dialog. I wanted to close this open file dialog, but IDE froze, it was totally stuck (when I pressed
Ctrl+C in the command line, IDE was still there, "killall java" - no problem, IDE was still there, I had to use "kill
-9")...

Thread dump follows.
Comment 1 Petr Dvorak 2008-07-14 09:14:11 UTC
Created attachment 64405 [details]
Thread Dump
Comment 2 Peter Pis 2008-08-16 00:07:54 UTC
*** Issue 144131 has been marked as a duplicate of this issue. ***
Comment 3 Marian Petras 2008-08-21 15:09:56 UTC
The call-stack of thread "AWT-EventQueue-1", which caused the hang, demonstrates that the freeze occurred during
repainting the heap view display. The Open File dialogue does not explicitly request any locks so the bug is either in
the heap view code or in AWT/Swing. Reassigned to "openide/actions" for further evaluation.
Comment 4 Petr Nejedly 2008-08-25 16:07:15 UTC
*** Issue 144931 has been marked as a duplicate of this issue. ***
Comment 5 Petr Nejedly 2008-08-26 11:08:43 UTC
Very strange painting lockup with no apparent reason.
Unrelated to apisupport/timers, probably even unrelated to memory bar (which is in core, IIRC), which was just
unfortunate enough to try to paint at wrong time...
Comment 6 David Simonek 2008-08-26 11:56:37 UTC
Nothing I can do with this, sorry, because issue is random, reason not known and thread dumps related to lock ends in
not-netbeans code.

Please reopen if it happens more frequently under some circumstances, ideally with reproducible scenario, although I
know it isn't likely.
Comment 7 Petr Dvorak 2008-08-26 12:06:27 UTC
OK, I will reopen if I meet it again. Verified for now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo