Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 139659 - UnsatisfiedLinkError: jnidispatch (/com/sun/jna/win32-amd64/jnidispatch.dll) not found in resource path
UnsatisfiedLinkError: jnidispatch (/com/sun/jna/win32-amd64/jnidispatch.dll) ...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P2 (vote)
: 6.x
Assigned To: mslama
issues@platform
http://statistics.netbeans.org/except...
65fixes2-verified
:
: 149815 (view as bug list)
Depends on:
Blocks: 145435
  Show dependency treegraph
 
Reported: 2008-07-11 00:41 UTC by _ gtzabari
Modified: 2009-02-19 22:53 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2008-07-11 00:41:55 UTC
Build: NetBeans IDE 6.1 (Build 200804211638)
VM: Java HotSpot(TM) 64-Bit Server VM, 10.0-b22, Java(TM) SE Runtime Environment, 1.6.0_06-b02
OS: Windows Vista, 6.0, amd64
User comments: 
Moving the output tab to its own window.

STACKTRACE: (first 10 lines)
java.lang.UnsatisfiedLinkError: jnidispatch (/com/sun/jna/win32-amd64/jnidispatch.dll) not found in resource path
        at com.sun.jna.Native.loadNativeLibrary(Native.java:468)
        at com.sun.jna.Native.<clinit>(Native.java:91)
        at com.sun.jna.Pointer.<clinit>(Pointer.java:38)
        at com.sun.jna.PointerType.<init>(PointerType.java:25)
        at org.netbeans.core.nativeaccess.transparency.win32.W32API$HANDLE.<init>(W32API.java:79)
        at org.netbeans.core.nativeaccess.transparency.win32.W32API$HWND.<init>(W32API.java:92)
        at org.netbeans.core.nativeaccess.transparency.WindowUtils$W32WindowUtils.getHWnd(WindowUtils.java:567)
        at org.netbeans.core.nativeaccess.transparency.WindowUtils$W32WindowUtils.access$300(WindowUtils.java:565)
        at org.netbeans.core.nativeaccess.transparency.WindowUtils$W32WindowUtils$1.run(WindowUtils.java:618)
        at
org.netbeans.core.nativeaccess.transparency.WindowUtils$NativeWindowUtils$2.hierarchyChanged(WindowUtils.java:342)
Comment 1 _ gtzabari 2008-07-11 00:43:15 UTC
As a workaround Tools -> Options -> Miscellaneous -> Appearance -> "Transparent *" should be unchecked on 64-bit JDKs.
See http://www.mucommander.com/cgi-bin/bugzilla/show_bug.cgi?id=57 and
https://jna.dev.java.net/issues/show_bug.cgi?id=59 for more information.
Comment 2 David Simonek 2008-07-11 15:42:51 UTC
What are we expected to do here? Automatically disable (grey out) mentioned transparency option if 64-bit JDK on windows
is detected?
Comment 3 _ gtzabari 2008-07-11 15:44:22 UTC
That's an easy fix. I did exactly that manually and it works fine. Once JNA releases 64-bit versions we can re-enable
it. That being said, I get an uncomfortable feeling JNA won't be fixing that bug for a long time.
Comment 4 David Simonek 2008-07-11 16:35:56 UTC
Patch welcomed for this easy fix, I have hundreds on other easy fixes waiting :)
Comment 5 _ gtzabari 2008-07-11 16:37:33 UTC
Sorry, I didn't mean to imply "this is an easy fix, go fix it". I simply meant "the easiest way to fix it would be to
disable the checkboxes by default".
Comment 6 David Simonek 2008-07-14 07:44:29 UTC
Yes, agreed, and no problem (smile was there...) 
Comment 7 Exceptions Reporter 2008-08-12 02:55:37 UTC
This issue has already 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=50238
Comment 8 David Simonek 2008-08-13 16:55:17 UTC
Hopefully fixed:

http://hg.netbeans.org/main/rev/fe8c2a99e468

gtzabari or other reporters, could you please verify with dev build that will contain fix above (tomorrow's or aftre
tomorrow's), I don't have access to win 64, thanks.
Comment 9 _ gtzabari 2008-08-27 04:23:47 UTC
I just tried dev build 200808261401... Oddly enough drag-n-drop tabs fades out just fine, even under x64. So I see two
issues here:

1) Why is this working under x64 now?
2) Shouldn't your patch have disabled this feature under x64?
Comment 10 David Simonek 2008-08-27 11:11:09 UTC
1) Why is this working under x64 now?
I don't know.

2) Shouldn't your patch have disabled this feature under x64?
Yes, for "amd64". If OS arch type contains "amd64" then JNA usage is disabled - for me it's working, look at the patch,
I think it is right.
You are referring to "x64" not "amd64", maybe that's the source of confusion?

Anyway no exceptions are reported after my fix went into the build, so I guess it is really fixed.

Comment 11 _ gtzabari 2008-08-28 00:09:55 UTC
x64 and amd64 are one and the same. Anyway, I'll leave this issue as closed for now seeing as it doesn't produce any
negative behavior. Thanks ;)
Comment 12 David Simonek 2008-10-24 11:04:37 UTC
*** Issue 149815 has been marked as a duplicate of this issue. ***
Comment 13 David Simonek 2008-10-24 11:06:53 UTC
Ma fix apparently failed for some reason, as duplicate issue shows. As I don't have access to 64 bit Vista, I'm unable
to fix the bug, calling community for help.
Comment 14 mslama 2008-12-08 18:34:11 UTC
I will check. I have Vista 64bit at home. os.arch system property value should be always 'amd64' on 64bit JDK.
Comment 15 mslama 2008-12-09 12:27:31 UTC
Updated jna to 3.09. with 64bit Windows support.

core-main #ba7e26c4d653

I will test and remove last change which should disable this functionality on amd64 arch on Windows.
Comment 16 mslama 2008-12-09 12:41:39 UTC
core-main #949dbe23c0fd

Remove disabling jna for 64bit Windows as jna 3.0.9 supports 64bit Windows.
Comment 17 mslama 2008-12-09 12:43:46 UTC
I will test at home later today. Of course other testers are also welcome. You can get latest build at
http://deadlock.netbeans.org/hudson/job/NB-Core-Build/. Fix should be in next build. Please check that first.
Comment 18 mslama 2008-12-09 21:27:43 UTC
I checked with build #1854 from http://deadlock.netbeans.org/hudson/job/NB-Core-Build and it works fine with 64bit JDK
on Windows Vista. Please verify. Dragged tabs are transparent and no exception is logged on console.
Comment 19 Quality Engineering 2008-12-10 05:59:27 UTC
Integrated into 'main-golden', will be available in build *200812100201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/949dbe23c0fd
User: Marek Slama <mslama@netbeans.org>
Log: #139659: Remove special handling of amd64 arch for Windows as JNA now supports Win 64bit.
Comment 20 mslama 2009-01-12 12:59:27 UTC
Please be aware that this fix consists of 2 stages:

1.First part was to add special handling of reported exception ie. hide it.
2.Second part was to remove patch 1 and update jna external library as new version supports 64bit Windows.

It not clear if 1 or 2 should be backported (ie. I do not know if it is possible to update jna library through patch -
if yes then it is ok. If not I would recommend to leave it as it is or at least test that hiding exception works as
there was report that it does not work. As I directly updated jna lib I did not test stage 1.
Comment 21 Jaromir Uhrik 2009-01-12 17:01:03 UTC
Verified.
Comment 22 pgebauer 2009-01-15 00:14:18 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/313d81b1e346


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo