Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 138441 - View Refresh does not work for me
View Refresh does not work for me
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Derby
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: John Baker
issues@db
:
Depends on:
Blocks: 152673
  Show dependency treegraph
 
Reported: 2008-06-27 08:13 UTC by oflebbe
Modified: 2008-11-24 16:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oflebbe 2008-06-27 08:13:04 UTC
Hi,

If I create a view with an derby db, and I hit refresh, the "Views" Tree element within the "Servers" tab is correctly
updated. 

However, if I drop the view (no refresh) and recreate it with an additional column, the "views" tree elemnt is not
updated: The additional column does not show up. 

If I close the connection and reconnect, the "Views" will show the additional column.

Not sure if it is derby, java 1.6., netbeans 6.1 or windows xp specific.

Cheers
  Olaf
Comment 1 John Baker 2008-08-22 00:32:29 UTC
oflebbe the following works for me.  If you have any additional information, please add it to this issue

Using the sample table [app on APP]

1) Right-click on Views - the Create View dialog opens
2) Enter a name for the view:
       CUST
   and enter a SQL:
       SELECT CUSTOMER_ID, NAME FROM CUSTOMER

- the CUST view is created under the VIEWS node

3) Right-click and choose Delete to drop CUST
4) Repeat step 2 but this time include another column:

          SELECT CUSTOMER_ID, NAME, CITY FROM CUSTOMER

5) Expand the Views node and CUST 

- there are 3 columns: CUSTOMER_ID, NAME and CITY   


Reporter, i
Comment 2 David Vancouvering 2008-09-24 19:53:04 UTC
We were not able to get to these issues before code freeze - changing target
milestone to 'future'
Comment 3 Roman Mostyka 2008-10-22 12:41:26 UTC
oflebbe, can You update this issue? Are You still able to reproduce this issue?
We can't work on this issue since we don't have enough information. If this issue isn't updated and still in INCOMPLETE
state, then we will think that it isn't valid anymore (probably was fixed with another issue) and this issue will be closed.
Comment 4 Roman Mostyka 2008-11-24 16:16:47 UTC
We haven't got any new info in a month, so I'm closing this issue as FIXED.
Please reopen this issue if it is still valid and add some more information.
Comment 5 Roman Mostyka 2008-11-24 16:20:42 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo