Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 137990 - Incorrect handling requires/providers deps in Download tab
Incorrect handling requires/providers deps in Download tab
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on: 145016
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-23 16:24 UTC by Alexandr Scherbatiy
Modified: 2008-09-14 21:03 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2008-06-23 16:24:38 UTC
Steps to reproduce:

- Download and install the nightly NetBeans build
 http://bits.netbeans.org/download/trunk/nightly/latest
- Try to install JavaFX Script plugin 
  The plugin is not installed because of missing dependency:
  
  Missing required dependency for Plugin JavaFX Projects:
  module org.netbeans.modules.javawebstart.signtask > 1.0
Comment 1 Alexei Mokeev 2008-07-09 12:17:45 UTC
It is still reproducible for you with the current daily builds ?
Comment 2 Alexandr Scherbatiy 2008-07-09 12:21:06 UTC
It is reproduced with the latest netbeans build that is not a NB 6.1 (it is probably a NB 6.5).
Comment 3 Alexei Mokeev 2008-07-09 12:51:04 UTC
Compatibility with 2 versions of Netbeans at the same time is a separate question, since Netbeans 6.5 is out of scope
for the current release. I'm downgrading this to P3, Andrey will take a look after Preview. 
Comment 4 Andrey Yamkovoy 2008-09-02 13:34:31 UTC
Not reproducible on the latest NB trunk build
Comment 5 Alexandr Scherbatiy 2008-09-03 10:12:57 UTC
The latest nbms are not installed on my NetBeans 6.5

 JavaFX_trunk_NB_Plugin_NB65_cont:  #97 03-Sep-2008 12:16:33
 
  Product Version         = NetBeans IDE Dev (Build 200809021401)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11; Sun Microsystems Inc.

Some plugins require plugin org.netbeans.modules.api.debugger.javafx to be installed.
The plugin org.netbeans.modules.api.debugger.javafx was requested in version 1.0.  The following plugin is affected:
      JavaFX Debugger 
Some plugins require plugin org.netbeans.modules.javafx.editor to be installed.
The plugin org.netbeans.modules.javafx.editor was requested in version 1.1.  The following plugin is affected:
      JavaFX Debugger 
Some plugins require plugin org.netbeans.modules.javafx.lexer to be installed.
The plugin org.netbeans.modules.javafx.lexer was requested in version 1.2.1.  The following plugin is affected:
      JavaFX Debugger 
Some plugins require plugin org.netbeans.modules.javafx.lib to be installed.
The plugin org.netbeans.modules.javafx.lib was requested in version 1.1.  The following plugin is affected:       JavaFX
Debugger  Some plugins not installed to avoid potential installation problems
Comment 6 Andrey Yamkovoy 2008-09-03 11:41:11 UTC
All dependencies in the plugin are correct.
Looks like a plugin manager issue because it's possible to install all javafx nbms one by one.

Comment 7 Jiri Rechtacek 2008-09-03 11:50:31 UTC
Dupl of issue 145902. Fixed in core-main

*** This issue has been marked as a duplicate of 145902 ***
Comment 8 Jiri Rechtacek 2008-09-04 12:37:12 UTC
Not a dup.
Comment 9 Jiri Rechtacek 2008-09-04 16:28:34 UTC
fixed in rev/8b123b58eb6f
Comment 10 Lark Fitzgerald 2008-09-04 21:39:49 UTC
I can still reproduce this.  I installed:
Product Version: NetBeans IDE Dev (Build 20080904173750)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b14
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)

I tried to install fx plugin CB #103.  When I do, I get:
Some plugins require capability javafx.sdk
No plugin providing the capability javafx.sdk could be found.  The following plugin is affected:       JavaFX Kit 
Some plugins require capability org.netbeans.api.debugger.javafx.JavaFXDebuggerEngineImpl
No plugin providing the capability org.netbeans.api.debugger.javafx.JavaFXDebuggerEngineImpl could be found.  The 
following plugin is affected:       JavaFX Debugger UI
Comment 11 Jiri Rechtacek 2008-09-04 22:41:17 UTC
The fix is still waiting in core-main repository for pushing into main rep. Watch this issue until come notification
(something like this: Integrated into 'main-golden', will be available in build *200809040201*) about pushing into
main-golden in a few days. That notification haven't came yet.
Comment 12 Martin Ryzl 2008-09-05 08:35:48 UTC
could this fix be pushed sooner? It is a *real* blocker for our teams and users since it is the only distribution mechanism?
Comment 13 Quality Engineering 2008-09-05 17:30:48 UTC
Integrated into 'main-golden', will be available in build *200809051401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/8b123b58eb6f
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #137990: Incorrect handling requires/providers deps in Download tab
Comment 14 Lark Fitzgerald 2008-09-05 18:51:26 UTC
Tested using FX Cont trunk build 103 on NB6.5:
Product Version: NetBeans IDE Dev (Build 200809051401)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b14
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)
Comment 15 mbien 2008-09-14 17:58:18 UTC
can not verify fix with latest trunk builds

tested with:
http://bits.netbeans.org/download/trunk/nightly/2008-09-06_02-01-42/zip/netbeans-trunk-nightly-200809060201-javase.zip
and
http://bits.netbeans.org/download/trunk/nightly/2008-09-14_02-01-42/zip/netbeans-trunk-nightly-200809140201-javase.zip

200809051401 seems to be not available.

result:

Some plugins require plugin org.netbeans.modules.javawebstart.signtask to be installed.
The plugin org.netbeans.modules.javawebstart.signtask is requested in version 1.0.  
The following plugin is affected:
       JavaFX Projects

do I have to do anything special to get the build with the fix?
Comment 16 Lukas Hasik 2008-09-14 21:03:23 UTC
any NB build after 09/05 should contain the fix. However the "FX Cont trunk build" isn't public afaik


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo