Bug 136967 - Should be able to edit multiple fields in ShowData by tabbing
Should be able to edit multiple fields in ShowData by tabbing
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Show Data
6.x
Macintosh All
: P2 (vote)
: 8.2
Assigned To: Libor Fischmeistr
issues@db
: PATCH_AVAILABLE
: 155986 206101 (view as bug list)
Depends on:
Blocks: 152820
  Show dependency treegraph
 
Reported: 2008-06-11 01:17 UTC by David Vancouvering
Modified: 2014-12-09 04:21 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Proposed patch (2.48 KB, patch)
2014-09-01 21:06 UTC, mastero23
Details | Diff
Proposed patch v2 (2.49 KB, patch)
2014-09-03 19:29 UTC, mastero23
Details | Diff
Fix insert record dialog (1.83 KB, patch)
2014-09-03 19:30 UTC, mastero23
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Vancouvering 2008-06-11 01:17:55 UTC
Right now if you edit a field in the ShowData component, you have to use your mouse to edit each field at a time.  This
is a big impact on usability.

We should allow the user to use their keyboard to tab through multiple entries at a time.  

Making it a P1 because I believe this has a significant impact on usability.  But note it's marked as an enhancement,
not a defect :)
Comment 1 _ ahimanikya 2008-06-18 05:03:35 UTC
Lets do this in the end if we get some time.
Comment 2 David Vancouvering 2008-06-18 06:14:05 UTC
FYI, the way you do this is by setting the target milestone to "future" rather than closing the bug.
Comment 3 _ ahimanikya 2008-08-29 06:46:07 UTC
I did not find any easy way to do this. I have also not seen this feature other SQL editors, downgrading.
Comment 4 _ ahimanikya 2008-12-17 11:27:36 UTC
This is mostly fixed in new Insert Dialog
Comment 5 Jiri Rechtacek 2009-10-16 14:15:11 UTC
Reassigned to new owner.
Comment 6 mastero23 2014-09-01 21:06:10 UTC
Created attachment 148982 [details]
Proposed patch

This patch allows continuous editing of multiple cells if you use TAB or SHIFT-TAB to navigate.
Comment 7 matthias42 2014-09-02 17:04:19 UTC
This looks very good! I tested on linux with the LAFs: Metal, Nimbus, CDE, Gtk. They all work.

Please have a look at InsertRecordDialog.java, there InsertRecordTableUI is subclassed and changeSelection is overriden to implement the behaviour you archived here (your version looks much saner). I commented out the inline override (lines 123-146, Version from main-golden) and the behavior you implemented works correctly also in the input dialog.
Comment 8 mastero23 2014-09-03 19:29:04 UTC
Created attachment 149029 [details]
Proposed patch v2
Comment 9 mastero23 2014-09-03 19:30:01 UTC
Created attachment 149030 [details]
Fix insert record dialog
Comment 10 mastero23 2014-09-03 19:43:31 UTC
I've attached a new patch that removes the lines 129-144 from InsertRecordDialog.java. I didn't remove the complete changeSelection function, because it enables the 'Remove' button. This patch also fixes #206101.

There's a new version of the original patch. In v1 there was no cursor when StringTableCellEditor got the focus.
Comment 11 matthias42 2014-09-04 19:22:45 UTC
I gave it another spin and this looks good - the unittest still work, the behaviour is the desired one. I think this is good to be committed.

@Libor - could you please give it another look and commit it (both patches are needed)?
Comment 12 matthias42 2014-10-05 18:26:28 UTC
*** Bug 155986 has been marked as a duplicate of this bug. ***
Comment 13 matthias42 2014-10-05 18:27:04 UTC
*** Bug 206101 has been marked as a duplicate of this bug. ***
Comment 14 Libor Fischmeistr 2014-12-08 11:35:01 UTC
Reviewed on Windows. Looks good to me.

Patch and fix applied in changeset http://hg.netbeans.org/core-main/rev/789a98ecc677

Thanks to Markus for the patch and Matthias for the review.
Comment 15 Quality Engineering 2014-12-09 04:21:50 UTC
Integrated into 'main-silver', will be available in build *201412090001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/789a98ecc677
User: Libor Fischmeistr <lfischmeistr@netbeans.org>
Log: #136967: Should be able to edit multiple fields in ShowData by tabbing


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo