Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136539 - Editor is not responsive for large .sql files
Editor is not responsive for large .sql files
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: PERFORMANCE
Depends on: 121357
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 10:47 UTC by Petr Jiricka
Modified: 2008-06-09 11:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (15.01 KB, text/plain)
2008-06-05 14:20 UTC, Andrei Badea
Details
Attaching the file in a zip file. The longest line in the file is >200,000 characters. (654.85 KB, application/octet-stream)
2008-06-07 22:30 UTC, Petr Jiricka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2008-06-05 10:47:48 UTC
1. Download the Sakila db sample from the mysql website
2. Open the sakila-data.sql file in the editor

=> The editor is not responsive, scrolling is very slow.
Comment 1 Andrei Badea 2008-06-05 14:20:34 UTC
Created attachment 62410 [details]
Thread dump
Comment 2 Andrei Badea 2008-06-05 14:21:51 UTC
All thread dumps I took show the editor being busy drawing.
Comment 3 Andrei Badea 2008-06-05 16:49:40 UTC
By the way, the file I and the reporter tested with has very long lines, perhaps that could be the cause.
Comment 4 Vitezslav Stejskal 2008-06-07 12:35:33 UTC
The new view hierarchy will hopefully perform better. How long lines are we talking? Could you attach sakila-data.sql
here (perhaps in a .zip form)? Thanks
Comment 5 Petr Jiricka 2008-06-07 22:30:48 UTC
Created attachment 62528 [details]
Attaching the file in a zip file. The longest line in the file is >200,000 characters.
Comment 6 Vitezslav Stejskal 2008-06-09 11:18:41 UTC
Oh well, that's it then. I opened sakila-data.sql and although the editor was sluggish it seemed to handle the file
quite well. The longest line I found was 1.032.623 characters long. I pasted it to OpenOffice and it created 338 pages
of text, the number of characters is from the document statistics. GEdit didn't even render a line like this for
example. Anyway, the editor with current view hierarchy can handle seamlessly lines with ~100k characters (see issue
#114016), which IMO is beyond any practical use. The new hierarchy should perform even better, but the task hasn't made
it to any schedule yet.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo