Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136535 - Can not change compiler options in duplicated configuration
Can not change compiler options in duplicated configuration
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
6.x
All Linux
: P3 (vote)
: 6.x
Assigned To: Thomas Preisler
issues@cnd
67patch1-verified
:
: 133213 167245 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 10:31 UTC by mg2000
Modified: 2009-07-17 13:59 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mg2000 2008-06-05 10:31:19 UTC
C project has default 2 configurations.(Debug/Release)

I copied configuration 'Release' to 'Copy_Of_Release'

And add some text to [preprocessor definitions] in 'Copy_Of_Release'

But when I build using 'Copy_Of_Release', Makefile doesn't have preprocessor definition.

When I build using 'Release', Makefile is genereated correctly.
Comment 1 Thomas Preisler 2008-07-10 22:16:35 UTC
Problem confirmed. If you close and reopen the project it works fine.
Comment 2 Thomas Preisler 2008-09-19 22:26:51 UTC
*** Issue 133213 has been marked as a duplicate of this issue. ***
Comment 3 Thomas Preisler 2008-09-19 22:28:35 UTC
Something is wrong in the master chain of CC/C configurations.
Comment 4 Thomas Preisler 2008-10-06 23:10:10 UTC
Workaround is to close and re-open project. Probably won't fix for 6.5.
Comment 5 Quality Engineering 2009-04-25 07:28:48 UTC
Integrated into 'main-golden', will be available in build *200904250201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7819a3e0340f
User: Nick N. Krasilnikov <nnnnnk@netbeans.org>
Log: fixing IZ#136535 : cannot set preprocessor definition
Comment 6 nnnnnk 2009-04-30 15:14:25 UTC
The problem locates in MakeConfiguration copy().
auxObjectsMap contains ItemConfigurations and FolderConfigurations. 
This classes have links to configurations (lastConfiguration, cCompilerConfiguration, ccCompilerConfiguration).
During a copy process we do not change this configurations.
But this configurations contains links to old master configutarions.

So the problem in coping of graph in unpredictable order.
Comment 7 Thomas Preisler 2009-06-17 17:52:50 UTC
*** Issue 167245 has been marked as a duplicate of this issue. ***
Comment 8 Alexander Pepin 2009-06-18 10:53:03 UTC
Unfortunately closing and re-opening the project does not help. The workaround is to *restart IDE*.
 IMO now it's high time to fix such issues and do not postpone them till end of a new development cycle when I believe
we will have enough new issues to fix.
Comment 9 Thomas Preisler 2009-06-19 06:08:51 UTC
Fixed.
Comment 10 Quality Engineering 2009-06-19 20:25:23 UTC
Integrated into 'main-golden', will be available in build *200906191401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/492d05041bd2
User: Thomas Preisler <thp@netbeans.org>
Log: #136535 Can not change compiler options in duplicated configuration
Comment 11 Alexander Pepin 2009-06-22 16:29:08 UTC
verified in dev build.
It should be a candidate for 6.7 patch1.
Comment 12 pgebauer 2009-07-01 09:04:54 UTC
The fix has been ported into the release61_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/0593123ba307
Comment 13 pgebauer 2009-07-01 09:18:23 UTC
The fix has been ported into the release67_fixes repository, of course. The release61_fixes is a typo.


Comment 14 Alexander Pepin 2009-07-15 16:57:27 UTC
verified in nb6.7.1rc


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo