Bug 136501 - IDE hangs / freezes when attempting to open a file
IDE hangs / freezes when attempting to open a file
Status: RESOLVED DUPLICATE of bug 132662
Product: javaee
Classification: Unclassified
Component: JSP Parser
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@javaee
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 21:12 UTC by deorwin
Modified: 2008-06-13 11:39 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
NetBeans IDE 6.1 stack trace generated at 1pm on June 5, 2008 (38.14 KB, text/plain)
2008-06-05 21:01 UTC, deorwin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deorwin 2008-06-04 21:12:16 UTC
Inconsistently, but very frequently, the IDE hangs / freezes completely when double-clicking a file to open it in the 
project explorer.  I also notice that when selecting the file, the navigation pane says "please wait" forever; then the 
IDE seems to consistently freeze when double-clicking / opening that file.

I also have the Maven IDE plugin installed and had been working with a Maven J2EE project.

There is no way to recover from the hang, I need to force-terminate NetBeans and restart the IDE.
Comment 1 exsuscito 2008-06-05 00:05:45 UTC
After deactivating the Subversion plugin and using the IDE for two hours, files open quicker and the IDE does not seem 
to hang/freeze sporadically anymore.
Comment 2 Jiri Prox 2008-06-05 08:44:34 UTC
Cam you please capture threaddump of the frozen ide.
Thanks

http://wiki.netbeans.org/GenerateThreadDump
Comment 3 deorwin 2008-06-05 21:00:02 UTC
In order to reproduce the issue, I already had NetBeans loaded so I went to plugins and "reactivated" Subversion 
plugin.  This did not require restarting the IDE, so I did not restart the IDE.  After many hours of problem-free 
developing with Subversion re-activated, I decided to restart the IDE.  Immediately after trying to open up a "blue" 
J2EE tag file (i.e. blue meaning "locally modified") the IDE froze again.

I will attach a thread dump generated by AdaptJ StackTrace in the next follow-up.
Comment 4 deorwin 2008-06-05 21:01:08 UTC
Created attachment 62435 [details]
NetBeans IDE 6.1 stack trace generated at 1pm on June 5, 2008
Comment 5 Vitezslav Stejskal 2008-06-07 12:23:30 UTC
Thanks for the info. I'm not sure what exactly was wrong, but it looks like a problem somewhere between JSP parser,
CloneableEditorSupport and maybe GSF. Marek or Jarda might know more...
Comment 6 deorwin 2008-06-10 00:49:08 UTC
Not specific to Subversion plugin anymore, the freeze ocurred twice with Subversion plugin completely deactivated.
Comment 7 Tomas Mysik 2008-06-12 09:58:20 UTC
Adding Marek to CC - could you please have a look whether this issue is not related to issue #136601? I can't see any 
deadlock in thread dump. Thanks.
Comment 8 Tomas Mysik 2008-06-13 11:39:30 UTC
Very likely a duplicate of issue #132662.


*** This issue has been marked as a duplicate of 132662 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo