Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 135931 - make "go to file" (control-shift-O) faster
make "go to file" (control-shift-O) faster
Status: RESOLVED DUPLICATE of bug 122639
Product: utilities
Classification: Unclassified
Component: Jump To
6.x
Macintosh Mac OS X
: P3 with 3 votes (vote)
: TBD
Assigned To: Petr Hrebejk
Jiri Prox
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 19:30 UTC by andre_lewis
Modified: 2009-01-27 17:17 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andre_lewis 2008-05-27 19:30:04 UTC
On a large project, Control-Shift-O takes up to 5-6 seconds or so to locate files. In comparison, Aptana offers the same
functionality (Apple-shift-R) and it is instantaneous, even on huge projects. 

I think lots of developers use these shortcuts as the primary means of navigating around projects. Even though it seems
like a small detail, this is the key thing that's keeping me on Aptana instead of NetBeans.
Comment 1 richo 2008-09-16 11:35:52 UTC
On linux using a continuous build (13 Sept 2008) of 6.5 "go to file" is fast, even across multiple projects. Perhaps try
6.5 and see if that is any better, or maybe it is Mac specific.
Comment 2 zyclops 2008-09-17 09:00:20 UTC
It still takes a good 3 seconds on OSX under 6.5  

Having this cached and instant pretty much means that you don't have to navigate by trying to locate tabs which is a lot
faster.
Comment 3 jimbojones 2008-09-17 09:05:18 UTC
Definitely not just a Mac issue. On Windows I can make a cup of coffee in the time it takes to use this feature.... OK
its a tiny cup of coffee but coming from other IDE's that handle this much faster is painful.
Comment 4 Petr Hrebejk 2008-09-17 09:39:14 UTC
For fast navigation (not using tabs) use the go to type instead of go to file Ctrl+O. That uses indexed information and
is faster.
Comment 5 zyclops 2008-09-17 09:52:49 UTC
That will definitely help! Thanks for the tip.  There are still some cases when i'd prefer to search for files (i.e. for
non-object based js and css files) but go to type covers 80% of cases.
Comment 6 Jesse Glick 2009-01-27 17:17:30 UTC

*** This issue has been marked as a duplicate of 122639 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo