Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 135827 - Remove implementation dependency in
Remove implementation dependency in
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Samaresh Panda
issues@xml
61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 16:31 UTC by Lukas Hasik
Modified: 2008-07-10 15:09 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-05-26 16:31:52 UTC
there is implementation dependency in org.netbeans.modules.xml.schema.completion module. We would like to remove
implementation dependencies in IDE. The implementation dependencies can cause problems during update and patching.

HERE is it - *org.netbeans.modules.xml.retriever/1 = 200805230103*


Snip of the catalog.xml
<module autoload="false" codenamebase="org.netbeans.modules.xml.schema.completion"
distribution="modules/ide9/org-netbeans-modules-xml-schema-completion_patch1.nbm" downloadsize="56256" eager="false"
homepage="http://www.netbeans.org/" license="8B813426" moduleauthor="" needsrestart="false" releasedate="2008/05/23"
targetcluster="ide9">
<manifest AutoUpdate-Show-In-Client="false" OpenIDE-Module="org.netbeans.modules.xml.schema.completion"
OpenIDE-Module-Display-Category="XML" OpenIDE-Module-Implementation-Version="200805230103"
OpenIDE-Module-Java-Dependencies="Java > 1.5" OpenIDE-Module-Module-Dependencies="org.netbeans.api.xml/1 > 1.14,
org.netbeans.modules.editor.completion/1 > 1.6.11, org.netbeans.modules.editor.lib/1 > 1.9.11.1,
org.netbeans.modules.lexer/2 > 1.26, org.netbeans.modules.projectapi/1 > 1.12, org.netbeans.modules.xml.axi > 1.2,
org.netbeans.modules.xml.lexer > 1.2, org.netbeans.modules.xml.retriever/1 = 200805230103,
org.netbeans.modules.xml.schema.model/1 > 1.3.1, org.netbeans.modules.xml.text/2 > 1.13.0.4.4,
org.netbeans.modules.xml.xam/1, org.openide.filesystems > 6.4.11, org.openide.loaders > 5.9.11, org.openide.nodes >
6.7.11, org.openide.util > 6.8.11, org.openide.windows > 6.5.11" OpenIDE-Module-Name="Schema Aware Code Completion"
OpenIDE-Module-Requires="org.openide.modules.ModuleFormat1" OpenIDE-Module-Specification-Version="1.1.1"/>
</module>
Comment 1 Samaresh Panda 2008-05-28 18:55:20 UTC
working on it...
Comment 3 Lukas Hasik 2008-06-04 13:41:19 UTC
this is definitely candidate for patch2 of 6.1
Comment 4 jinb 2008-06-05 11:05:37 UTC
QA, please verify this fix till 09-Jun-2008, so it can be part of NB 6.1 patch 2.
Comment 5 Lukas Hasik 2008-06-06 16:38:49 UTC
I'm marking as verified. I checked the commit logs. They look fine.
BUT it has to be checked with the nbm (or better AUC) built from the release61_fixes repository.
Jaro, could you please take care of this? Thank you.
Comment 6 jinb 2008-06-09 18:36:44 UTC
fix backported into release61_fixes branch
http://hg.netbeans.org/release61_fixes/rev/86db619f228e


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo