Bug 134612 - No profiling data taken from application
No profiling data taken from application
Status: RESOLVED WONTFIX
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC All
: P2 (vote)
: TBD
Assigned To: issues@profiler
issues@profiler
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 14:54 UTC by Maksim Khramov
Modified: 2008-09-05 15:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maksim Khramov 2008-05-06 14:54:57 UTC
Product Version: NetBeans IDE 6.1 (Build 200804211638)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 11.0-b11

Steps to reproduce:
Create and run DocumentEditor sample application.
Invoke attach profiler dialog.
Create custom configuration.
Select profile part of application and select only main() method as root.
Select Profile exclude Java core classes.
Switch to advanced pane and check "Profile new Threads/Runnables"

Attach to application.
In profiled application type text in editor.
Look at Live Results. There are no data from profiled application.

See also VisualVM bug #132
Comment 1 Tomas Hurka 2008-06-16 14:45:34 UTC
I am afraid that there are no new Threads/Runnables after you attach to DocumentEditor sample application. Am I right?
Comment 2 mariadavydova 2008-09-05 11:54:24 UTC
Comment from VisualVM: The cause is probably a limitation of NB profiler which only profiles newly
started runnables when no root methods (startclasses in VisualVM) are defined.
Could you please check it with NB profiler (using local dynamic attach which is
used by VisualVM) and eventually file an issue there & update+close this issue?
Thanks.

Update: I checked this issue with local dynamic attach. The same happens when you just type something. 
And there is Editor data in results after you save file or do something else. Please comment this behavior.
Comment 3 Tomas Hurka 2008-09-05 15:52:04 UTC
Maria is right, profiler needs root methods to get some data. There is no root method hit when you type text in editor. Closing as  WONTFIX, since this is how 
the profiler works. We can enhance profiler functionality when doing dynamic attach to somehow figure out root methods and you don't have root methods 
defined.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo