Bug 134595 - Improve handling of plugin pending status
Improve handling of plugin pending status
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P2 (vote)
: 6.x
Assigned To: dlipin
issues@platform
http://statistics.netbeans.org/except...
67patch1-fixed
:
: 119882 121857 130529 149946 150119 156058 158770 163064 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 12:50 UTC by Jaromir Uhrik
Modified: 2009-10-09 10:49 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.79 KB, text/plain)
2009-06-10 12:19 UTC, Michael Nazarov
Details
stacktrace (2.70 KB, text/plain)
2009-06-16 10:17 UTC, Jiri Kovalsky
Details
stacktrace (3.80 KB, text/plain)
2009-07-01 09:27 UTC, Jiri Kovalsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2008-05-06 12:50:36 UTC
[NetBeans 6.1 fcs]
When the plugin is in pending state then it is not possible to install other plugin depending on such pending plugin. I
am not sure whether this is defect or enhancement - seems to me like a feature. But it would be very valuable to have it
fixed because it breaks possibility of install modules one by one in the tests.
Steps to reproduce:
-Install Ruby and Rails (at the end of installer select "Restart IDE Later")
-Install Ruby Extra Hints 
-> installation cannot continue because of the message below

---------------------------------%<----------------------------
Missing required modules for Plugin Ruby Extra Hints:
JRuby Implementation is waiting for restart IDE. 
Ruby Hints is waiting for restart IDE. 
Ruby Editing is waiting for restart IDE.
---------------------------------%<----------------------------

Similarly when adding the plugin to a container via API it causes exception like following:

java.lang.IllegalArgumentException: Invalid org.netbeans.modules.ruby.platform for operation INSTALL at
org.netbeans.modules.autoupdate.services.OperationContainerImpl.add(OperationContainerImpl.java:103) at
org.netbeans.api.autoupdate.OperationContainer.add(OperationContainer.java:277) at
org.netbeans.updatecenters.install.InstallTest.installPlugin(InstallTest.java:290) at
org.netbeans.updatecenters.install.InstallTest.runTest(InstallTest.java:254) at
org.netbeans.junit.NbTestCase.access$200(NbTestCase.java:83) at
org.netbeans.junit.NbTestCase$2.doSomething(NbTestCase.java:314) at
org.netbeans.junit.NbTestCase$1Guard.run(NbTestCase.java:252) at
org.netbeans.junit.NbTestCase.runBare(NbTestCase.java:330) at junit.framework.TestResult$1.protect(TestResult.java:106)
at junit.framework.TestResult.runProtected(TestResult.java:124) at junit.framework.TestResult.run(TestResult.java:109)
at junit.framework.TestCase.run(TestCase.java:120) at org.netbeans.junit.NbTestCase.run(NbTestCase.java:192) at
junit.framework.TestSuite.runTest(TestSuite.java:230) at junit.framework.TestSuite.run(TestSuite.java:225) at
org.netbeans.xtest.testrunner.JUnitTestRunner.runTests(JUnitTestRunner.java:191) at
org.netbeans.xtest.testrunner.JUnitTestRunner.runTests(JUnitTestRunner.java:146) at
org.netbeans.xtest.plugin.ide.MainWithExec.run(MainWithExec.java:108) at
org.netbeans.xtest.plugin.ide.Main$3.run(Main.java:326) at java.lang.Thread.run(Thread.java:619)
Comment 1 Antonin Nebuzelsky 2008-11-14 15:32:18 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 2 dlipin 2008-11-19 12:14:56 UTC
*** Issue 119882 has been marked as a duplicate of this issue. ***
Comment 3 dlipin 2008-11-19 12:16:33 UTC
*** Issue 149946 has been marked as a duplicate of this issue. ***
Comment 4 dlipin 2008-11-19 12:16:35 UTC
*** Issue 150119 has been marked as a duplicate of this issue. ***
Comment 5 dlipin 2008-12-25 11:13:35 UTC
*** Issue 156058 has been marked as a duplicate of this issue. ***
Comment 6 Exceptions Reporter 2009-01-29 18:36:01 UTC
This issue has already 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=6455
Comment 7 dlipin 2009-02-10 15:55:48 UTC
*** Issue 121857 has been marked as a duplicate of this issue. ***
Comment 8 dlipin 2009-02-11 13:52:03 UTC
*** Issue 130529 has been marked as a duplicate of this issue. ***
Comment 9 dlipin 2009-02-20 12:36:55 UTC
*** Issue 158770 has been marked as a duplicate of this issue. ***
Comment 10 Exceptions Reporter 2009-04-18 20:23:14 UTC
This issue already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=6455
Comment 11 dlipin 2009-04-21 14:00:26 UTC
*** Issue 163064 has been marked as a duplicate of this issue. ***
Comment 12 dlipin 2009-04-27 11:37:41 UTC
Reproducible test case is very appreciated.
Comment 13 Egor Ushakov 2009-05-25 10:48:25 UTC
I installed NB Dev 20090525 (Java only) and deactivated team module - got the exception
Comment 14 Michael Nazarov 2009-06-10 12:18:58 UTC
Build: NetBeans IDE 6.7 RC3 (Build 200906100001)
VM: Java HotSpot(TM) Client VM, 10.0-b23, Java(TM) SE Runtime Environment, 1.6.0_07-b06
OS: SunOS, 5.11, x86

User Comments: 


Stacktrace: 
java.lang.IllegalArgumentException: Invalid org.netbeans.modules.php.kit for operation UNINSTALL
        at org.netbeans.modules.autoupdate.services.OperationContainerImpl.add(OperationContainerImpl.java:106)
        at org.netbeans.api.autoupdate.OperationContainer.add(OperationContainer.java:275)
        at org.netbeans.modules.autoupdate.ui.Unit$Installed.setMarked(Unit.java:311)
        at org.netbeans.modules.autoupdate.ui.InstalledTableModel.setValueAt(InstalledTableModel.java:154)
        at javax.swing.JTable.setValueAt(JTable.java:2663)
        at javax.swing.JTable.editingStopped(JTable.java:4662)
Comment 15 Michael Nazarov 2009-06-10 12:19:14 UTC
Created attachment 83397 [details]
stacktrace
Comment 16 dlipin 2009-06-10 12:43:29 UTC
Michael, please provide exacts steps to reproduce the issue. Thanks.
Comment 17 Michael Nazarov 2009-06-10 12:48:48 UTC
Looks like they skipped by exception reported.
Open Plugins.
Activate PHP plugin.
Deactivate PHP and Cancel reboot.
Deactivate PHP again, choose Reboot later.

I found slightly different behavior for root/user and user/user installation/usage,
but overall result seems to be the same. In first case Deactivate button remains
enabled in second case doesn't.
Comment 18 Jiri Kovalsky 2009-06-16 10:17:47 UTC
Build: NetBeans IDE 6.7 RC2 (Build 200906042131)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_04-b12
OS: Linux, 2.6.20-17-generic, i386

User Comments: 
I was playing with XSLT Debugger plugin [1]. Later I decided to first deactivate it and then changed my mind and I wanted to uninstall it completely.

[1] http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=17747

Stacktrace: 
java.lang.IllegalArgumentException: Invalid dougmcneil.name.xslt.debugger for operation UNINSTALL
        at org.netbeans.modules.autoupdate.services.OperationContainerImpl.add(OperationContainerImpl.java:106)
        at org.netbeans.api.autoupdate.OperationContainer.add(OperationContainer.java:275)
        at org.netbeans.modules.autoupdate.ui.Unit$Installed.setMarked(Unit.java:311)
        at org.netbeans.modules.autoupdate.ui.InstalledTableModel.setValueAt(InstalledTableModel.java:154)
        at javax.swing.JTable.setValueAt(JTable.java:2663)
        at javax.swing.JTable.editingStopped(JTable.java:4662)
Comment 19 Jiri Kovalsky 2009-06-16 10:17:56 UTC
Created attachment 83621 [details]
stacktrace
Comment 20 Jiri Kovalsky 2009-06-16 10:31:26 UTC
Why is this incomplete? I did exactly the same as Michael described but with XSLT Debugger plugin. Installed it into 6.7
RC2, played with it, then checked it in Plugins/Installed tab, deactivated it and postponed required restart of the IDE
because I wanted to get rid of it completely right away not later.
Comment 21 dlipin 2009-06-16 18:56:12 UTC
This particular issue should be fixed together with 166806.
Comment 22 Jiri Kovalsky 2009-07-01 09:27:03 UTC
Build: NetBeans IDE 6.7 (Build 200906241340)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_04-b12
OS: Linux, 2.6.20-17-generic, i386

User Comments: 
Installed Automatic Projects, switched to Installed tab, then Deactivated the plugin, postponed Restart of the IDE to happen later and then checked the Automatic Projects entry again.

Stacktrace: 
java.lang.IllegalArgumentException: Invalid org.netbeans.modules.autoproject.java for operation UNINSTALL
        at org.netbeans.modules.autoupdate.services.OperationContainerImpl.add(OperationContainerImpl.java:106)
        at org.netbeans.api.autoupdate.OperationContainer.add(OperationContainer.java:275)
        at org.netbeans.modules.autoupdate.ui.Unit$Installed.setMarked(Unit.java:324)
        at org.netbeans.modules.autoupdate.ui.InstalledTableModel.setValueAt(InstalledTableModel.java:154)
        at javax.swing.JTable.setValueAt(JTable.java:2663)
        at javax.swing.JTable.editingStopped(JTable.java:4662)
Comment 23 Jiri Kovalsky 2009-07-01 09:27:07 UTC
Created attachment 84225 [details]
stacktrace
Comment 24 Exceptions Reporter 2009-07-01 09:27:26 UTC
This issue already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=6455
Comment 25 dlipin 2009-07-01 09:50:30 UTC
This issue (with this particular stacktrace) is fixed in 6.8 by
http://hg.netbeans.org/main-golden/rev/eead235cea13
Comment 26 dlipin 2009-07-02 11:21:27 UTC
Jiri (Kovalsky), Michael, and others,

could you please verify that it is fixed in development builds?
http://bits.netbeans.org/dev/nightly/latest/

I want to include this bug fix into the next 6.7 patch.
Thanks,
Dmitry
Comment 27 Marian Mirilovic 2009-07-08 13:51:02 UTC
verified in NB Dev (20090708)
Comment 28 pgebauer 2009-07-08 14:47:23 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/901459b1cb1b
Comment 29 pgebauer 2009-07-22 15:19:08 UTC
Could somebody explain to me why the 67patch1-fixed status whiteboard has been removed even though the changeset 901459b1cb1b wasn't rolled back 
from the release67_fixes branch?
Comment 30 Michael Nazarov 2009-07-22 15:22:50 UTC
Sorry, looks like my mistake.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo