Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 134484 - TypeCast does not work for entities other then Copy (If, While, ForEach, ...)
TypeCast does not work for entities other then Copy (If, While, ForEach, ...)
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL Mapper
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Nikita Krjukov
issues@soa
affects-docs, 61fixes2-fixed
:
Depends on: 135604
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-04 14:01 UTC by Nikita Krjukov
Modified: 2008-07-10 15:07 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
You can see the problem with the attached project (9.62 KB, application/octet-stream)
2008-05-04 14:05 UTC, Nikita Krjukov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Krjukov 2008-05-04 14:01:05 UTC
It is impossible to work with TypeCast feature for BPEL entities other then Copy.
After reloading the BPEL mapper, it doesn't show the same state.

Steps to reproduce:
- Open any BPEL project 
- Add While 
- Switch to BPEL mapper
- Create a new Type Cast
- Draw a link from an item inside of the TypeCast
- Reload the mapper

Now the link goes from the original item but not from the casted.
Comment 1 Nikita Krjukov 2008-05-04 14:05:44 UTC
Created attachment 61020 [details]
You can see the problem with the attached project
Comment 2 Nikita Krjukov 2008-05-04 14:06:14 UTC
The issue is fixed in the trunk
Comment 3 Nikita Krjukov 2008-05-06 10:22:46 UTC
Here is the changeset in the trunk
http://hg.netbeans.org/main/rev/516f5823ce87
Comment 4 Nikita Krjukov 2008-05-06 10:24:29 UTC
I mark it as fixed because it is fixed in the trunk
Comment 5 Sergey Lunegov 2008-05-21 13:02:39 UTC
Patch2 canidate
Comment 6 Andrei Chistiakov 2008-05-22 14:25:10 UTC
I'm unable to verify this fix until issue 135604 is fixed.
Comment 7 pslechta 2008-05-28 14:08:08 UTC
QA, please verify this fix till 09-Jun-2008, so it can be part of NB 6.1 patch 2.
Comment 8 Andrei Chistiakov 2008-05-29 11:07:20 UTC
Verified with NetBeans IDE Dev (Build 200805280004).
Comment 9 pslechta 2008-05-29 12:54:13 UTC
The fix has been ported into the release61_fixes repository.

http://hg.netbeans.org/release61_fixes/rev/a26c2eeda439
http://hg.netbeans.org/release61_fixes/rev/d4694517728e


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo