Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 134238 - java.io.FileNotFoundException: Sample databases not created. Restart NetBeans or create the folder not found. C:\Documents and Settings\gaweraj\.netbeans-derby
java.io.FileNotFoundException: Sample databases not created. Restart NetBean...
Status: VERIFIED FIXED
Product: obsolete
Classification: Unclassified
Component: visualweb
6.x
All All
: P3 (vote)
: 6.x
Assigned To: John Baker
issues@obsolete
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 10:37 UTC by jgawera
Modified: 2008-07-10 15:11 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.60 KB, text/plain)
2008-04-30 10:37 UTC, jgawera
Details
stacktrace (1.60 KB, text/plain)
2008-05-13 21:53 UTC, thealchemist
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jgawera 2008-04-30 10:37:41 UTC
Build: NetBeans IDE 6.1 (Build 200804211638)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows XP, 5.1, x86

User Comments: 
Started up netbeans
Comment 1 jgawera 2008-04-30 10:37:57 UTC
Created attachment 60856 [details]
stacktrace
Comment 2 John Baker 2008-04-30 18:47:36 UTC
This path does not exist on your system:
C:\Documents and Settings\gaweraj\.netbeans-derby 

Try creating .netbeans-derby directory and restarting NetBeans

Comment 3 Exceptions Reporter 2008-05-06 14:18:55 UTC
This issue has already 20 duplicates 
Comment 4 thealchemist 2008-05-13 21:53:57 UTC
Created attachment 61355 [details]
stacktrace
Comment 5 John Baker 2008-05-13 22:16:33 UTC
thealchemist,  does this path exist on your system /nas1/projects/care/data/Aranzandi-word.pair.db  ?
Comment 6 John Baker 2008-05-14 18:03:24 UTC
Reproducible

1) Start NetBeans 5.5 or 6.0 with fresh userdir. Then close IDE.
2) Start NetBeans 6.1 with fresh userdir.
3) Click "Yes" in "Import Settings" dialog.
Comment 7 John Baker 2008-05-15 00:24:32 UTC
This looks like a db issue.

When importing settings from previous release and the .netbeans-derby folder does not exist the folder does not get
created.  

To reproduce:

1) Make sure .netbeans-derby folder does not exist in the user's HOME directory
2) Start NetBeans 5.5 or 6.0 with fresh userdir. Then close IDE.
3) Start NetBeans 6.1 with fresh userdir.
4) Click "Yes" in "Import Settings" dialog.

After IDE starts, no .netbeans-derby folder exists in the HOME directory
Comment 8 John Baker 2008-05-16 07:32:32 UTC
I think what's happening is if GF is not registered so no Java DB was created in a prior release then the
.netbeans-derby folder is not created.  Then when starting 6.1, visualweb looks for the .netbeans-derby folder and can't
find it.
Comment 9 John Baker 2008-05-19 00:44:11 UTC
http://hg.netbeans.org/main/rev/c3f838cdac3c

log the error instead of throwing an exception
Comment 10 Roman Mostyka 2008-05-19 15:15:30 UTC
Verified with build 080519.
Comment 11 John Baker 2008-05-19 21:27:15 UTC
I think this should be nominated for 6.1 patch 2
Comment 12 Quality Engineering 2008-05-20 05:06:56 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #206 build
Changeset: http://hg.netbeans.org/main/rev/c3f838cdac3c
User: John Baker <jbaker@netbeans.org>
Log: #134238 java.io.FileNotFoundException: Sample databases not created.  Restart NetBeans or create the folder not found. C:\Documents and Settings\gaweraj\.netbeans-derby
Comment 13 Roman Mostyka 2008-05-20 10:16:36 UTC
I agree. Mark this issue in appropriate way.
Comment 14 pgebauer 2008-05-26 08:56:22 UTC
The status-whiteboard value changed to correct one.
Comment 15 pslechta 2008-05-27 14:16:56 UTC
The fix has been ported into the release61_fixes repository.

http://hg.netbeans.org/release61_fixes/rev/166501e91113


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo