Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 134020 - Service Engine Service Unit from JBI Manager is not DnD-able into CASA
Service Engine Service Unit from JBI Manager is not DnD-able into CASA
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: Composite Application
6.x
All All
: P2 (vote)
: TBD
Assigned To: Jun Qian
issues@soa
61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-26 02:12 UTC by Jun Qian
Modified: 2008-07-10 15:14 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jun Qian 2008-04-26 02:12:50 UTC
Steps to reproduce:

1. Create SynchronousSample
2. Deploy SynchronousSampleApplication
3. Create a brand new CompApp project, open its CASA editor
4. Go to Services tab, expand the Servers/GlassFish V2/JBI/Service Assemblies/SynchronousSampleApplication node to show
the two service units
5. Drag the SynchronousSampleApplication-SynchronousSample service unit (exposed in step 4) into CASA editor's "External
Modules" region.  => It's not droppable.

The expected behavior is that service engine service unit (from JBI Manager) is droppable into CASA's "External Modules"
region. Note that binding component service unit (e.x., SynchronousSample3Application-sun-http-binding) is not droppable
by design.
Comment 1 Jun Qian 2008-04-26 02:25:42 UTC
Fixed in trunk: http://hg.netbeans.org/main?cmd=changeset;node=158fe29526f5
Comment 2 Jun Qian 2008-04-26 02:40:51 UTC
Jen, I think this is a candidate for NB 6.1 Patch 2.
Comment 3 Quality Engineering 2008-04-26 15:53:44 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #159 build
Changeset: http://hg.netbeans.org/main/rev/158fe29526f5
User: Jun Qian <jqian@netbeans.org>
Log: #134020 Fix DnD problem from JBI Manager to CASA.
Comment 4 vinathi 2008-04-29 20:57:20 UTC
Verified using 20080429-0500 build. It failed. Not sure which build to pick up in order to have the fix for the above 
mentioned issue. Awaiting developers response.
Comment 5 jbaragry 2008-05-21 10:43:07 UTC
This still fails in NetBeans-6.1-build-200805200103
Comment 6 Tientien Li 2008-05-21 16:48:56 UTC
Jason,

I think the build you used is not a post 6.1 trunk build. Please see the wiki page and following the step #1 to 
download the latest NetBeans trunk build.

http://wiki.netbeans.org/SoaFaqUseExternalServiceUnit

--
Tientien Li
Comment 7 pslechta 2008-05-28 14:07:05 UTC
QA, please verify this fix till 09-Jun-2008, so it can be part of NB 6.1 patch 2.
Comment 8 pgebauer 2008-06-10 13:41:39 UTC
This issue has been nominated for NB IDE 6.1 patch2 although it hasn't been verified by QE yet. If it isn't verified by
12-Jun-08, it's nomination will be removed.
Comment 9 jlautz 2008-06-12 22:39:20 UTC
Verified fixed as described in 

Product Version: NetBeans IDE Dev (Build 200806111204)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: SunOS version 5.10 running on x86; ISO646-US; en (nb)
Userdir: /Users/lautz/.netbeans/dev
Comment 10 pslechta 2008-06-13 10:29:36 UTC
The fix has been ported into the release61_fixes repository.

http://hg.netbeans.org/release61_fixes/rev/8fd0e2e5d1ba


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo