Bug 133988 - Code completion in the SQL editor
Code completion in the SQL editor
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: SQL Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Andrei Badea
issues@db
http://wiki.netbeans.org/DatabaseSQLC...
: PLAN
: 71369 (view as bug list)
Depends on: 133989
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-25 19:43 UTC by Andrei Badea
Modified: 2008-10-17 09:30 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Badea 2008-04-25 19:43:18 UTC
Provide code completion in the SQL editor, providing the names of the database objects, as well as SQL keywords.
Comment 1 Michel Graciano 2008-08-13 21:47:34 UTC
The TM is set as M2, but beta was released and just half of spec was implemented. Where is the INSERT/DELETE CC? It is a
really need feature. What is the new TM?
Comment 2 Andrei Badea 2008-08-14 10:59:57 UTC
INSERT/DELETE/UPDATE are not getting into 6.5. I believe CC for these statements is useful, since it helps you enter the
column and table names. However, what I think is not very useful is the keyword completion, which is also not doable
with our current, quite limited parser.
Comment 3 David Vancouvering 2008-10-16 23:00:43 UTC
*** Issue 71369 has been marked as a duplicate of this issue. ***
Comment 4 David Vancouvering 2008-10-16 23:01:23 UTC
Always more can be done, but this is basically completed as part of 6.5
Comment 5 Roman Mostyka 2008-10-17 09:30:20 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo