Bug 133751 - Missing API to obtain server host/port and (possibly) other props.
Missing API to obtain server host/port and (possibly) other props.
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Petr Hejl
issues@serverplugins
: API, API_REVIEW_FAST
: 77478 (view as bug list)
Depends on: 135324
Blocks: 126985 109895
  Show dependency treegraph
 
Reported: 2008-04-23 09:57 UTC by Petr Hejl
Modified: 2008-06-03 04:13 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
proposed change (18.43 KB, text/plain)
2008-05-22 15:17 UTC, Petr Hejl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hejl 2008-04-23 09:57:31 UTC
There is now no clean way how client could find out the server host/port. There is also no indication whether the server
is remote or local. This seems to be needed by several modules (ws, soa) - some of them are using terrible hack using
the leaking InstanceProperties (this is not reliable at all as there is no mandatory property for desired values).

We should provide api/spi representing ServerInstance (refactor subset of Deployment facade methods to it) and
ServerInstanceDescriptor (with methods to obtain host, port and remote flag).
Comment 1 Petr Hejl 2008-04-28 12:25:38 UTC
*** Issue 77478 has been marked as a duplicate of this issue. ***
Comment 2 Petr Hejl 2008-05-22 15:15:23 UTC
Attaching proposed change. The change is incremental to issue 135324 (diff expects that changes from 135324 are applied).
Comment 3 Petr Hejl 2008-05-22 15:17:48 UTC
Created attachment 61766 [details]
proposed change
Comment 4 Petr Hejl 2008-05-22 15:21:12 UTC
Please provide feedback on whether this change match your needs. Is any other instance property needed?
Comment 5 Petr Hejl 2008-05-29 10:10:36 UTC
If there are no objections, I'll push this tomorrow.
Comment 6 Petr Hejl 2008-05-30 11:44:42 UTC
Fixed in bb8f1225e3f6.
Comment 7 Quality Engineering 2008-06-03 04:13:09 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #234 build
Changeset: http://hg.netbeans.org/main/rev/bb8f1225e3f6
User: phejl@netbeans.org
Log: #133751 Missing API to obtain server host/port and (possibly) other props.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo