Bug 133688 - I18N - Several wizards don't resize to show warning message
I18N - Several wizards don't resize to show warning message
Status: RESOLVED DUPLICATE of bug 48815
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 16:39 UTC by kaa
Modified: 2008-12-22 14:46 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (100.77 KB, image/jpeg)
2008-04-22 16:40 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-04-22 16:39:26 UTC
Product Version: NetBeans IDE Dev (Build 200804210001)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
font size 16

Steps:
1. Open New Java Class wizard
2. Leave Package name empty

There is a warning message. The wizard doesn't resize to show it entirely.
The same in wizards for: entity class wizard, new javabean component, beaninfo, customizer, property editor.


Assumption is that user does not need to manually resize most windows or dialogs to see all of the UI objects and
information in them. I'm running in pseudo localized locale in which each message/label is sometimes longer than in
English. To account for that in some locales, translations from English (and some other euro languages) could be shown
with longer strings.

Also I'm running at font size 16, which is viewed as a valid font size that might be used. Resizing issues are not just
related to i18n; they might show to user in English locale if they run at larger font size.

Often, these issues happen because the length of some label or message or size of entire window is hardcoded vs using
layout managers or other techniques or api to have the windows or the objects in them, dynamically resize.
Comment 1 kaa 2008-04-22 16:40:32 UTC
Created attachment 60563 [details]
image
Comment 2 Ken Frank 2008-04-28 19:28:24 UTC
changing to java component - is that correct one
for this ? if not, please change or suggest what
the correct one is.

ken.frank@sun.com
Comment 3 Antonin Nebuzelsky 2008-05-07 12:12:09 UTC
A general wizard issue?
Comment 4 Antonin Nebuzelsky 2008-05-07 12:24:22 UTC
Jirko, is the warning text component at the bottom of panels provided by us? Maybe we could solve this issue by making
the text component multiline.

If not, separate issues should be filed against the individual wizards.
Comment 5 Jiri Rechtacek 2008-05-08 20:29:17 UTC
It's the known problem with which I can live since NB3.5.1 where this capability was introduced. Tracked also as issue
48815. Who using this capability to show a error message to end-users, should know that she has only limited space for
that message and design it to fit into there. Btw. end-user can invoke a tooltip over the error message if an end-users
doesn't see whole message.

*** This issue has been marked as a duplicate of 48815 ***
Comment 6 kaa 2008-09-09 15:06:38 UTC
Product Version: NetBeans IDE Dev (Build 200809040201)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22, WinXP, UTF-8 
I'm running in Japanese locale, using a pseudo localized Netbeans with font size 16 option.

The same for New WSDL Doc wizard (Document literal).
Appropriate tooltip exists.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo