Bug 133504 - Support for plugin verification against CA
Support for plugin verification against CA
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P2 (vote)
: TBD
Assigned To: Jaroslav Tulach
au-issues
: PLAN, UI
: 120250 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 18:58 UTC by Jiri Rechtacek
Modified: 2010-10-13 11:27 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2008-04-21 18:58:22 UTC
Allow verification of 3rd party plugin signature against CA and make corresponding changes in Plugin Manager's
installation wizard UI, i.e. Certificate Validation Warning dialog.
Comment 1 Jiri Rechtacek 2008-04-21 18:59:32 UTC
We're evaluating this RFE for next NetBeans release.
Comment 2 err 2008-04-22 03:50:45 UTC
Isn't this a regression? It use to work in NB5.5.

Some of the issues filed about this problem have "regression" in keywords, some don't. But since it used to work,
doesn't that make it a defect?
Comment 3 Jiri Rechtacek 2008-04-22 08:45:20 UTC
err, it cannot be a regression. Verification in NB6.1 works in as same way as NB5.5. If a plugin is signed by a
certification which was not trusted in NB so far and user has approved it, then NB add this certificate among trusted
and will not ask for confirmation again (fixed issue 123148).
This RFE is speaking about possibility to verify plugins against 3rd party Certificate Authority beside of current
NetBeans certification.
Comment 4 err 2008-04-23 01:31:04 UTC
Ah, my bad. Thanks for the clarification.
Comment 5 Jiri Rechtacek 2008-10-16 18:07:56 UTC
*** Issue 120250 has been marked as a duplicate of this issue. ***
Comment 6 Antonin Nebuzelsky 2008-11-14 15:32:27 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 7 Jaroslav Tulach 2010-10-13 11:27:32 UTC
Good idea, who's going to implement it?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo