Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133428 - Highlight layer doesn't updated
Highlight layer doesn't updated
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
61fixes2-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 11:12 UTC by Marek Fukala
Modified: 2008-07-10 15:06 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Fukala 2008-04-21 11:12:03 UTC
1) open an html file
2) put following code somewhere inside:

    <script language="javascript" type="text/javascript">
        function functionAlpha() {
        }
    </script>

=> the javascript has no green background
3) close/reopen the file
=> the background is ok

The update of the HL doesn't work after opening - if you for example change the <script to <sXcript the green background
should disappear.

This looks like to be a recent regression of the HL performance improvements. Please consider fix of this to go to 61
patch 1 as well.
Comment 1 Vitezslav Stejskal 2008-04-21 14:24:51 UTC
I'll have a look.
Comment 2 Vitezslav Stejskal 2008-04-21 15:52:45 UTC
Please double check the fix. http://hg.netbeans.org/main/rev/d4d275ab42da
Comment 3 Jindrich Sedek 2008-05-06 11:47:33 UTC
verified
NetBeans IDE Dev (Build 200804290004)
Comment 4 pgebauer 2008-05-29 00:04:14 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/rev/c3108e08eab4


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo