Bug 13299 - Compilation ends with org.openide.filesystems.FSException
Compilation ends with org.openide.filesystems.FSException
Status: CLOSED FIXED
Product: javaee
Classification: Unclassified
Component: Code
-FFJ-
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: Petr Jiricka
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-29 10:02 UTC by L Martinek
Modified: 2003-07-02 08:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
webmodule to test Build All (4.19 KB, application/octet-stream)
2001-06-29 10:03 UTC, L Martinek
Details
There is the exceptions. (11.55 KB, text/plain)
2001-06-29 10:16 UTC, Petr Pisl
Details
The proposed patch for the problem. (512 bytes, patch)
2001-07-02 14:52 UTC, Petr Jiricka
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description L Martinek 2001-06-29 10:02:16 UTC
[010628]

Try to Build All on directory with many JSP. Compilation ends with exception in 
output window. Try it more times if exception doesn't occurs for the first time.
Comment 1 L Martinek 2001-06-29 10:03:16 UTC
Created attachment 1776 [details]
webmodule to test Build All
Comment 2 Petr Pisl 2001-06-29 10:16:58 UTC
Created attachment 1777 [details]
There is the exceptions.
Comment 3 Petr Pisl 2001-06-29 10:23:58 UTC
The exceptions never occur in the first time. Usually in the second time, when 
you try Build All action. Then the exceptions occures always if you excute 
Build All. 

The file, which IDE can't delete, exists on  the disk
Comment 4 Petr Jiricka 2001-06-29 20:47:35 UTC
It looks like the file is still open when the compiler attempts to delete it, 
because the file can not be deleted even from the OS.

Likely to be a Windows-specific problem.
Comment 5 Petr Jiricka 2001-07-02 14:51:47 UTC
This is caused by the code which constructs JSP debugging information. This 
code reads the servlet file to construct the information.

In one place of the code a reader is opened which reads the file, but is never 
closed, or even used. This code should have been deleted when the JSP debugging 
was refactored to use the server integration APIs, but it was somehow omitted 
in the code. Now this causes that the servlet file is locked, and can not be 
deleted.
Comment 6 Petr Jiricka 2001-07-02 14:52:35 UTC
Created attachment 1808 [details]
The proposed patch for the problem.
Comment 7 Petr Jiricka 2001-07-12 14:30:31 UTC
Fixed on 2001/07/12
Comment 8 L Martinek 2001-07-13 10:46:23 UTC
verified in 010712
Comment 9 Quality Engineering 2003-07-02 08:28:52 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo