Bug 132907 - StringIndexOutOfBoundsException during indexing C:\
StringIndexOutOfBoundsException during indexing C:\
Status: VERIFIED DUPLICATE of bug 131552
Product: php
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Marek Fukala
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 17:38 UTC by Victoria Zhukovskaya
Modified: 2008-04-29 12:05 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (182.63 KB, text/plain)
2008-04-15 17:39 UTC, Victoria Zhukovskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Victoria Zhukovskaya 2008-04-15 17:38:19 UTC
1. Create new PHP project with default settings
2. Invoke properties for the php project
3. Change source folder to "C:\" f.e.
4. Press Ok.

5. wait more then 2 min. see process of indexing C:\ in status
6.  Try to create new php project during indexing


result 
1. Exception
java.lang.StringIndexOutOfBoundsException: String index out of range: 0
	at java.lang.String.charAt(String.java:687)
	at org.netbeans.modules.html.editor.coloring.EmbeddingUpdater.startTag(EmbeddingUpdater.java:134)
	at org.netbeans.modules.html.editor.coloring.EmbeddingUpdater.parsingFinished(EmbeddingUpdater.java:120)
	at org.netbeans.editor.ext.html.parser.SyntaxParser.notifyParsingFinished(SyntaxParser.java:238)
	at org.netbeans.editor.ext.html.parser.SyntaxParser.parse(SyntaxParser.java:222)
	at org.netbeans.editor.ext.html.parser.SyntaxParser.access$200(SyntaxParser.java:69)
	at org.netbeans.editor.ext.html.parser.SyntaxParser$4.run(SyntaxParser.java:151)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)

2. Warning
The file index-all.html seems to be too large .... 


And here is attached message.log
Comment 1 Victoria Zhukovskaya 2008-04-15 17:39:11 UTC
Created attachment 60219 [details]
messages.log
Comment 2 Tomas Mysik 2008-04-15 20:09:37 UTC
Not the issue of PHP project but editor - so reassigning, please evaluate.
One note - selecting C:\ as a source root is not valid use case IMHO. Adding Petr to CC because this issue could be 
interesting from the performance point of view.
Comment 3 Victoria Zhukovskaya 2008-04-16 09:32:21 UTC
I agree that C:\ is not valid folder. But I think that if user can do so threre should not be exceptions.
Thank You for comments
Comment 4 Petr Pisl 2008-04-16 11:16:28 UTC
The exception is from html lexer. This doesn't look like php problem. Marek, could you evaluate it?
Comment 5 Marek Fukala 2008-04-16 12:01:37 UTC

*** This issue has been marked as a duplicate of 131552 ***
Comment 6 Jiri Prox 2008-04-25 13:09:34 UTC
The number of next version is already known -> moving from TM Dev to 6.5
Comment 7 Victoria Zhukovskaya 2008-04-29 12:05:15 UTC
verfied in Build 20080429082942
no exception.



By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo