Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132863 - NB becomes frozen with code completion.
NB becomes frozen with code completion.
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@editor
61fixes1-fixed
:
: 135840 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 11:14 UTC by tetsu
Modified: 2008-06-04 08:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tetsu 2008-04-15 11:14:43 UTC
I am using NB 6.1 RC1 and working on Windows XP with JDK 1.6.0_05.

Steps:
1. open a Java class in Java editor;
2. input "sysout";
3. Press "Ctrl + Space" to invoke code completion and editor says "No Suggestions".
4. Press "Backspace" to delete letters one by one and editor will try to give you suggestion basing on the left word.
You will get lots of suggestions when "sys" is left. 
By the way, it is weird. With input of "sys", editor will only give one suggestion in normal way.

5. Keep deleting letters. When only "s" is left, the editor tries very hard to give you suggestion and NB becomes frozen.
6. The situation becomes worse when you delete the last "s" and "" is left. The editor will freeze even longer.
Comment 1 Max Sauer 2008-04-15 11:26:32 UTC
This happens to me also.
---
Product Version: NetBeans IDE Dev (Build 20080331051557)
Java: 1.6.0_04-dp; Java HotSpot(TM) 64-Bit Server VM 1.6.0_04-b12-45-optimized
System: Mac OS X version 10.5.2 running on x86_64; MacRoman; en_US (nb)
Comment 2 Dusan Balek 2008-04-23 09:06:06 UTC
Fixed.

changeset f9247d1c9426 in main
details: http://hg.netbeans.org/main?cmd=changeset;node=f9247d1c9426
Comment 3 Quality Engineering 2008-04-23 15:53:39 UTC
Issue '132863' Integrated in NB_Trunk_Production #153 : http://hg.netbeans.org/main/rev/f9247d1c9426,
 with comment: Issue #132863: NB becomes frozen with code completion - fixed.
Comment 4 Jiri Prox 2008-04-24 08:18:40 UTC
verified in trunk, another good candidate for patch 1
Comment 5 pgebauer 2008-04-28 22:01:26 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/main?cmd=changeset;node=f9247d1c9426
Comment 6 Dusan Balek 2008-06-02 21:27:23 UTC
*** Issue 135840 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo