Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132386 - DEADLOCK at .text.CloneableEditor$DoInitialize.initVisual(CloneableEditor.java:367)
DEADLOCK at .text.CloneableEditor$DoInitialize.initVisual(CloneableEditor.jav...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Text
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
61fixes1-fixed
:
: 134873 148784 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 09:44 UTC by Martin Schovanek
Modified: 2008-12-22 14:22 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (28.38 KB, text/plain)
2008-04-09 09:46 UTC, Martin Schovanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2008-04-09 09:44:08 UTC
[#20080409, jdk1.5.0]

to reproduce:
-------------
1) have opened a Web project + index.jsp + ext-all-debug.js + simple.js
2) restart the IDE
ERROR: IDE throws following NPE and deadlocks:
java.lang.NullPointerException
	at org.openide.text.CloneableEditor$DoInitialize.run(CloneableEditor.java:261)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
Comment 1 Martin Schovanek 2008-04-09 09:46:17 UTC
Created attachment 59889 [details]
Thread dump
Comment 2 Vitezslav Stejskal 2008-04-09 09:49:58 UTC
Jardo, help please! :-)
Comment 3 Vitezslav Stejskal 2008-04-09 10:09:11 UTC
Martine, were there any other exceptions in the log file? It looks like the document was not loaded for some reason...
Comment 4 Martin Schovanek 2008-04-09 10:19:38 UTC
Any other visible exception, but the document is use to throw another NPE, see issue # 132374.
Comment 5 Jaroslav Tulach 2008-04-09 10:34:42 UTC
I've seen it yesterday as well and it was not related to web or jsp. I think I was working with plain java se project 
and java sources.
Comment 6 Jaroslav Tulach 2008-04-09 14:51:21 UTC
The NPE can happen only if Timers/Counters module is enabled. There is "if (TIMER.isLoggable(Level.FINE))" check 
around line 261. Timers/Counters module is never part of release, that is why I do not think this needs to be fixed 
for 6.1.
Comment 7 Jaroslav Tulach 2008-04-09 15:33:54 UTC
changeset:   77610:b4ac2c895887
tag:         tip
user:        Jaroslav Tulach <jtulach@netbeans.org>
date:        Wed Apr 09 16:33:09 2008 +0200
summary:     #132386: Fix NPE when logging CloneableEditor info to Timers/Counters module

Comment 8 Marian Mirilovic 2008-04-10 22:13:14 UTC
> Timers/Counters module is never part of release
It wasn't for NB 6.0.1 , but I see it in NB 6.1 RC1 - Tonda, is it intentional ? I mean the whole memory toolbar is
disabled by default, but plugin is part of the build and memory toolbar can be enabled as well.
Comment 9 Lukas Hasik 2008-04-22 07:21:09 UTC
mschovanek, could you please verify in trunk? Thank you!
Comment 10 Lukas Hasik 2008-04-24 09:26:23 UTC
*** Issue 133236 has been marked as a duplicate of this issue. ***
Comment 11 Lukas Hasik 2008-04-24 19:28:56 UTC
although we are not able to reproduce it the test can simulate. I'm marking as verified. 
Comment 12 pgebauer 2008-04-27 19:41:02 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/rev/13b0d13260a0
Comment 13 Jaromir Uhrik 2008-05-19 16:45:41 UTC
mschovanek, could you please verify in 6.1fcs+patch1? Thank you!
Comment 14 Martin Schovanek 2008-05-19 16:52:03 UTC
Vewrified in 6.1fcs+patch1.
Comment 15 mslama 2008-06-25 15:13:34 UTC
*** Issue 134873 has been marked as a duplicate of this issue. ***
Comment 16 mslama 2008-10-01 11:54:04 UTC
*** Issue 148784 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo