Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 132232 - Unable to install UML update or to uninstall UML
Unable to install UML update or to uninstall UML
Status: RESOLVED DUPLICATE of bug 122186
Product: uml
Classification: Unclassified
Component: General
6.x
PC Other
: P4 (vote)
: TBD
Assigned To: issues@uml
issues@uml
EXT-USER
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 18:00 UTC by djkernen
Modified: 2008-04-07 19:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description djkernen 2008-04-07 18:00:03 UTC
Hi, I am running NB IDE 6.0.1 on Vista and have installed the UML plugin. When I select the plugin in the plugin mgr it
says it is running UML 1.2.1. There is an update for UML 1.2.3 in my available updates tab, but if I allow that update
to go in it will fail. Specifically, it will install and prompt me to restart nb, and when I do I receive an error
message that UML wants the 1.2.3 core lib but I only have 1.2.1. I must then either disable the module or exit the IDE.

I saw posts online that indicated that by uninstalling the plugin and re-installing it would work, presumably because I
would then pull in the correct version of the core library so everything would be cool. But I cannot uninstall the module!

Here's what happens:

If I have the UML update installed (the one that requires 1.2.3), then if I elect to uninstall UML then that update will
be uninstalled, the update will again be listed in the Updates tab in the plugin mgr and the Installed tab will show UML
1.2.1. (It will however now have a green check=active versus the red X = inactive that it has after the update is applied.)

If, however, I do not have the UML update installed (which is to say that I have just the 1.2.1 UML core active and
available) then if I try to uninstall it, nothing eventually happens. It appears to be uninstalling, it prompts me to
restart the IDE, and when I do there is a brief window that asks me to please wait while it uninstalls, but then if I go
into the plugin mgr I still see the UML plugin listed as an installed plugin.
Comment 1 djkernen 2008-04-07 18:25:17 UTC
UPDATE: I was able to uninstall the 1.2.1 release by opening an explorer window and right clicking on the netbeans.exe
and selecting "Run as Administrator". Then I uninstalled the UML plugin and selected "Restart now" when prompted. And
that worked! So... Surprise! It's a permissions issue with Vista! 
Comment 2 George Vasick 2008-04-07 19:06:54 UTC
We have a FAQ on this:
http://wiki.netbeans.org/FaqInstallPluginVista
and the problem is fixed for 6.1.

I will resolve this a duplicate.  Please reopen is that is not the case.

Thanks,
George

*** This issue has been marked as a duplicate of 122186 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo