Bug 132187 - Implement call hierarchy
Implement call hierarchy
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
6.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
: PLAN
: 60723 113458 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 13:55 UTC by Jan Becicka
Modified: 2008-06-16 04:17 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2008-04-07 13:55:30 UTC
Implement call hierarchy
Comment 1 Jan Becicka 2008-04-25 10:00:54 UTC
It would be nice to be able to viewing "chain" of method calls for a particular method. This is enhancement to Find
Usages feature known from competitive IDEs.
Comment 2 gborkowski 2008-06-05 09:43:55 UTC
From what I see, issues 60723 and 113458 are duplicates of this. But this one is a "task" so I perhaps there is some
difference, please verify ii. 
This feature is one of two which made me switch to Eclipse, and I can't go back to NetBeans now because of lack of them
(second is missing Type Hierarchy feature - I will file enhancement against it soon).
This is really really necessary for me now, when I'm analising code in some big project written by someone else. Being
able to track all the calls for given method in the tree-like manner is really indispensable is such a case.

Please see how it is done in Eclipse - they did really good job.
However, there is one thing missing in Eclipse implementation, which I think Netbeans can do better - I found no simple
way to disable showing calls from test classes. In most cases I'm not interested in such calls - but eclipse does not
have a clear way of distinguishing test classes and source classes (at least I don't know it). In Netbeans it is
different - test classes are treated logically in different way. So I would really like to have the tool to see calls
for given method in a tree-like manner, like in Eclipse, but with additional switch to hide calls coming from test classes.
I really believe this should be at least P2.
Comment 3 Jan Becicka 2008-06-05 09:52:02 UTC
gborkowski, prepare for switch. Type Hierarchy is already implemented (Alt-Shift-F12) and Call Hierarchy will be
available in 6.5M1.
Comment 4 gborkowski 2008-06-05 10:21:48 UTC
Good to hear it will be implemented soon.
Regarding TYpe Hierachy - Alt-Shift-F12 does not fit my needs.
See issue 136532 for description.
Comment 5 Jan Pokorsky 2008-06-05 10:36:28 UTC
*** Issue 60723 has been marked as a duplicate of this issue. ***
Comment 6 Jan Pokorsky 2008-06-05 10:47:01 UTC
*** Issue 113458 has been marked as a duplicate of this issue. ***
Comment 7 Jan Pokorsky 2008-06-05 14:47:33 UTC
gborkowski: It should be possible to filter out test classes.
Comment 8 Jan Pokorsky 2008-06-15 13:20:26 UTC
implemented as http://hg.netbeans.org/main/rev/a84ed0f8d79a
Comment 9 Quality Engineering 2008-06-16 04:17:08 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #262 build
Changeset: http://hg.netbeans.org/main/rev/a84ed0f8d79a
User: Jan Pokorsky <jpokorsky@netbeans.org>
Log: #132187: initial implementation of Java Call Hierarchy


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo