Bug 131931 - Exception on using HTML code completion
Exception on using HTML code completion
Status: RESOLVED DUPLICATE of bug 131929
Product: php
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: TBD
Assigned To: Tomasz Slota
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 13:56 UTC by kozlov
Modified: 2008-04-04 16:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kozlov 2008-04-03 13:56:45 UTC
Reproduced in build080402.

type 

<html>
</|

invoke CC and choose </html> form list

Exception:

java.lang.AssertionError
	at org.netbeans.modules.editor.structure.formatting.TagBasedLexerFormatter.reformat(TagBasedLexerFormatter.java:185)
	at org.netbeans.modules.editor.structure.formatting.TagBasedLexerFormatter.reformat(TagBasedLexerFormatter.java:160)
	at org.netbeans.modules.editor.structure.formatting.TagBasedLexerFormatter.process(TagBasedLexerFormatter.java:155)
	at org.netbeans.modules.html.editor.indent.HtmlIndentTask.reindent(HtmlIndentTask.java:68)
	at org.netbeans.modules.editor.indent.TaskHandler$MimeItem.runTask(TaskHandler.java:502)
	at org.netbeans.modules.editor.indent.TaskHandler.runTasks(TaskHandler.java:271)
	at org.netbeans.modules.editor.indent.IndentImpl.reformat(IndentImpl.java:293)
	at org.netbeans.modules.editor.indent.api.Reformat.reformat(Reformat.java:151)
	at org.netbeans.editor.ext.html.HTMLCompletionQuery$EndTagItem.reformat(HTMLCompletionQuery.java:801)
	at org.netbeans.editor.ext.html.HTMLCompletionQuery$HTMLResultItem.substituteText(HTMLCompletionQuery.java:643)
	at org.netbeans.editor.ext.html.HTMLCompletionQuery$EndTagItem.substituteText(HTMLCompletionQuery.java:785)
	at org.netbeans.editor.ext.html.HTMLCompletionQuery$HTMLResultItem.defaultAction(HTMLCompletionQuery.java:599)
	at org.netbeans.modules.editor.completion.CompletionImpl.dispatchKeyEvent(CompletionImpl.java:549)
	at org.netbeans.modules.editor.completion.CompletionImpl.keyPressed(CompletionImpl.java:350)
	at java.awt.AWTEventMulticaster.keyPressed(AWTEventMulticaster.java:192)
	at java.awt.AWTEventMulticaster.keyPressed(AWTEventMulticaster.java:191)
	at java.awt.Component.processKeyEvent(Component.java:5560)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2722)
	at java.awt.Component.processEvent(Component.java:5379)
	at java.awt.Container.processEvent(Container.java:2010)
	at java.awt.Component.dispatchEventImpl(Component.java:4068)
	at java.awt.Container.dispatchEventImpl(Container.java:2068)
	at java.awt.Component.dispatchEvent(Component.java:3903)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1826)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:681)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:938)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:810)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:645)
	at java.awt.Component.dispatchEventImpl(Component.java:3941)
	at java.awt.Container.dispatchEventImpl(Container.java:2068)
	at java.awt.Window.dispatchEventImpl(Window.java:1791)
	at java.awt.Component.dispatchEvent(Component.java:3903)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Petr Pisl 2008-04-03 15:29:01 UTC
Is it reproducible only in php files?
Comment 2 Tomasz Slota 2008-04-04 16:51:34 UTC

*** This issue has been marked as a duplicate of 131929 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo