Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131841 - NB freezes while refactoring
NB freezes while refactoring
Status: VERIFIED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: issues@guibuilder
issues@guibuilder
61fixes1-fixed
:
: 134079 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 15:47 UTC by Petr Dvorak
Modified: 2008-06-04 08:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE screenshot (110.20 KB, image/png)
2008-04-02 15:48 UTC, Petr Dvorak
Details
JStack: thread dump (17.18 KB, text/plain)
2008-04-02 15:49 UTC, Petr Dvorak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Dvorak 2008-04-02 15:47:28 UTC
Product Version: NetBeans IDE Dev (Build 200803311426)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

I tried to move the package from one package to another - NB just froze in the state displayed in the screenshot (I have
XP with Vista look, don't get confused), I had to kill it from the task manager.
Comment 1 Petr Dvorak 2008-04-02 15:48:41 UTC
Created attachment 59558 [details]
IDE screenshot
Comment 2 Petr Dvorak 2008-04-02 15:49:34 UTC
Created attachment 59559 [details]
JStack: thread dump
Comment 3 Jan Stola 2008-04-03 10:22:50 UTC
The deadlock is between Request Processor and Event Dispatch thread.

Request Processor is attempting to regenerate initComponents(). It checks whether this block was expanded (to be able 
to keep it expanded after regeneration). Unfortunately, the check must be performed in AWT => it uses invokeLaterAndWait
() to obtain this information. Request Processor thread is keeping FormModel lock at that time.

Unfortunately, there appeared some postponed (e.g. created via invokeLater()) update of the same form in AWT. This 
update is trying to lock the FormModel, but it is blocked.
Comment 4 Jan Stola 2008-04-03 12:28:05 UTC
The call to invokeLaterAndWait() was added because of issue 131068. I have removed it (which fixes this issue) and 
implemented a workaround for issue 131068.

Modified file: http://hg.netbeans.org/main?cmd=changeset;node=c68af088d6cb
Comment 5 Petr Dvorak 2008-04-14 11:56:26 UTC
Verified: 20080411

(Not reproducible anymore.)
Comment 6 Jana Maleckova 2008-04-17 13:23:06 UTC
hasn't been integrated into branch release61 yet. It's serious issue but not enough as to be showstopper for RC2 because
no data loss happens. All edited classes are saved before any action from refactoring is done.

Different steps how to reproduce it on RC2
1. have new j2se project
2. create new form class in package with main class
3. insert some component and switch auto i18n on (on form class)
4. try to rename this package => deadlock appears and IDE must be killed manually
Comment 7 Petr Dvorak 2008-04-21 15:29:32 UTC
Steps to reproduce submitted by Janie work - I have to reopen this issue. Deadlock appears after you perform above
mentioned steps.
Comment 8 Jan Stola 2008-04-21 16:04:54 UTC
> I have to reopen this issue. Deadlock appears after you perform above mentioned steps.

Could you, please, explain why did you reopen this issue? What build did you use to reproduce it. The issue was closed 
because it was fixed in the development builds, not in release61 branch.
Comment 9 Petr Dvorak 2008-04-21 16:47:16 UTC
oh... sh** - you are right... I used RC2... sorry for disturbing you there, guys...
Comment 10 Petr Dvorak 2008-04-21 16:49:10 UTC
Verified
Comment 11 rbalada 2008-04-25 16:59:21 UTC
Merged into release61_fixes repository

changeset:   77444:790a3dcb0d1c
user:        Jan Stola <jstola@netbeans.org>
date:        Thu Apr 03 13:02:55 2008 +0200
summary:     131841: Avoiding potential deadlock.
Comment 12 Jana Maleckova 2008-05-16 15:27:22 UTC
verified on
Product Version: NetBeans IDE 6.1 (Build 200804211638)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Comment 13 Jana Maleckova 2008-05-16 15:27:56 UTC
additional info .. v. on ide with patch1
Comment 14 Jan Stola 2008-05-28 13:42:59 UTC
*** Issue 134079 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo