Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131727 - META-INF services browser does not register service
META-INF services browser does not register service
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
61fixes1-fixed
: REGRESSION
: 134030 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 15:12 UTC by Tomas Danek
Modified: 2008-06-04 08:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2008-04-01 15:12:45 UTC
Product Version: NetBeans IDE Dev (Build 200804010004)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)
Userdir: /tmp/ud
-----------------
- create new module
- create some class
- try to register this class as a service using meta-inf services browser - file is created in META-INF folder, but is
empty. Regression from 6.0:-(
Comment 1 Jesse Glick 2008-04-01 16:04:32 UTC
aa72880d2664
Comment 2 Tomas Danek 2008-04-01 16:19:47 UTC
Is this fix really in TM=6.1? I suppose TM=Dev?
Comment 3 Jesse Glick 2008-04-01 16:32:25 UTC
Right, thanks for catching.
Comment 4 Tomas Danek 2008-04-22 10:30:14 UTC
verified in trunk 200804210001
Comment 5 pgebauer 2008-04-26 23:34:50 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/rev/2760b5186ae0
Comment 6 Tomas Danek 2008-04-29 11:44:50 UTC
*** Issue 134030 has been marked as a duplicate of this issue. ***
Comment 7 Tomas Danek 2008-05-16 13:44:37 UTC
verified also in 6.1 patch 1 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo