Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131053 - IDE freezed after "Copy&Paste" Configuration
IDE freezed after "Copy&Paste" Configuration
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Build System
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Petr Suchomel
issues@mobility
61fixes1-fixed
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 15:13 UTC by kate
Modified: 2008-06-04 08:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Dump (58.67 KB, text/plain)
2008-03-25 15:14 UTC, kate
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kate 2008-03-25 15:13:40 UTC
Product Version: NetBeans IDE Dev (Build 200803250006)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Mobility MIDP Application

- Open "Project Configurations" node in Projects Window
- Select some configuration. Invoke pop-up menu -> "Copy"
- Select "Project Configurations" node. Invoke pop-up menu -> "Paste"
- Type in some name

Cursor "Working .." is displayed but nothing happens (IDE freezed totally)

Console (thread) dump follows.
Comment 1 kate 2008-03-25 15:14:45 UTC
Created attachment 59027 [details]
Dump
Comment 2 Karol Harezlak 2008-03-25 17:10:11 UTC
It is caused by the  AWT thread lock, inside of the ProjectConfigurationHelper.setActiveConfiguration(...)

*** This issue has been marked as a duplicate of 130760 ***
Comment 3 kate 2008-04-07 11:10:52 UTC
Still persists for 200804040802 (both Linux, Win XP).
Comment 4 Petr Suchomel 2008-04-23 17:08:09 UTC
Fixed in trunk, forgot to get CS while struggling with the mercurial again and forever.
Comment 5 Quality Engineering 2008-04-24 03:52:40 UTC
Issue '131053' Integrated in NB_Trunk_Production #154 : http://hg.netbeans.org/main/rev/0fd30fd6a217,
 with comment: Fix for #131053 & #131056 - deadlocks. Root cause is the same for both bugs
Comment 6 Lukas Hasik 2008-04-24 15:55:51 UTC
verified in trunk

Product Version: NetBeans IDE Dev (Build 200804240003)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Userdir: F:\netbeans\userdir\nbDev0424
Comment 7 jinb 2008-04-29 19:13:08 UTC
fix backported into release61_fixes branch
Comment 8 jinb 2008-04-30 15:25:01 UTC
release61_fixes changeset: 77515: 5c8e63080ec1
Comment 9 Jaromir Uhrik 2008-05-19 16:47:46 UTC
Verified in 6.1fcs + patch1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo