Bug 130425 - I18N - need fix for 130235 for local history
I18N - need fix for 130235 for local history
Status: RESOLVED INVALID
Product: versioncontrol
Classification: Unclassified
Component: Localhistory
6.x
Sun Mac OS X
: P2 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 16:44 UTC by Ken Frank
Modified: 2008-04-22 23:04 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
image (133.86 KB, image/gif)
2008-03-18 18:33 UTC, Ken Frank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2008-03-18 16:44:51 UTC
see 130235 - Maros requested I file issue for local history for that situation.
Comment 1 Tomas Stupka 2008-03-18 17:51:37 UTC
there is no merge dialog in the local history
Comment 2 Ken Frank 2008-03-18 18:31:27 UTC
local history and the refactor
preview
diff view does not show the multibyte ok for one of the 2 diff windows
of each ?
Is that covered by this fix ?

using utf-8 or mac-roman(an euc-jp) encoding -

local history - current view mbyte is ok; previous one is not

refactor preview - current view is ok; to be refactored window is not

attached is gif.
Comment 3 Ken Frank 2008-03-18 18:33:36 UTC
Created attachment 58607 [details]
image
Comment 4 Ken Frank 2008-03-18 18:36:41 UTC
to clarify - 

1. what led to this being filed was what is seen on mac, which is attached

2. but in conversation with Maros, it was suggested to file issue also
on localhistory related to the fix he did in 130235.

===> this might really be 2 separate things that are needed, the fix for 2.
being done, but #1 might need a separate issue;; let me know.

ken.frank@sun.com
Comment 5 Tomas Stupka 2008-03-18 19:52:18 UTC
looking at 130235 it seems like the issue is about the merge tool which isn't used by local history at all.

however, what you have reported in your last post seems to be something else. i'll see if i can reproduce it...
Comment 6 Tomas Stupka 2008-03-25 15:46:58 UTC
i'm sorry but i'm unable to reproduce. 
Comment 7 Padraig Obriain 2008-03-31 08:32:39 UTC
This problem does not occur on mac 10.5 with mercurial 1.0 or mercurial 0.9.5.
It does occur with mac 10.4 with mercurial 0.9.5 (there is not currently mercurial 1.0 for mac 10.4)
Comment 8 novakm 2008-03-31 13:54:24 UTC
Last comment from Padraig was meant to be for issue 130245, please ignore.
Comment 9 Ken Frank 2008-03-31 16:34:02 UTC
am leaving as incomplete for now as am not able to reproduce now on 10.4 or 10.5
but need more time to experiment with this - am assuming if its incomplete that it
does not need to be waived for 6.1 ?

if that is not true please put at p3.

ken.frank@sun.com
Comment 10 Tomas Stupka 2008-04-16 23:17:47 UTC
hi, any update on this?
Comment 11 Ken Frank 2008-04-21 20:21:37 UTC
130235 was reopened but if there is no relation to functionality
of that and for local history  then I guess it can be closed -- 
but could you ask Maros about it first since he had mentioned
that similar fix for 130235 might be needed for this funcitonality -
and my interpretation of this might be - perhaps not as to the functionality itself, but the i18n or encoding handling
approach underneath it that might be common ?

ken.frank@sun.com
Comment 12 Tomas Stupka 2008-04-22 23:04:13 UTC
as already mentioned in my previous post - there is no relation between this one and 130235.

closing this until as we have no solid evidence at his point


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo