Bug 129495 - Netbeans 6 startup freeze at Opening Main Window...
Netbeans 6 startup freeze at Opening Main Window...
Status: RESOLVED FIXED
Product: obsolete
Classification: Unclassified
Component: Registration
6.x
PC All
: P2 (vote)
: 6.x
Assigned To: mslama
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-07 05:25 UTC by kiyut
Modified: 2008-03-13 15:32 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread Dump (11.71 KB, text/plain)
2008-03-08 17:25 UTC, kiyut
Details
Another Thread Dump (10.80 KB, text/plain)
2008-03-08 17:40 UTC, kiyut
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kiyut 2008-03-07 05:25:11 UTC
Hi,

Netbeans 6.0.1 is freezing when it is startup after displaying the main window, the status bar say "Opening Main
Window...", it just stop, I only can maximize and minimize the windows and nothing else, all the menu, tab, etc is not
responding to any mouse / click event. If I wait long enough eg: 10 min, finally it will normal again.

My guess Netbeans try to connect to internet and unable to do so, and it wait for timeout.

How to repeat the bug:
- Mess around with your dns setting (eg: change it to non existent dns server in your Network eg: 192.168.1.50), make
sure it is not able to resolve the domain and unable to access Internet
- Start Netbeans, it will free at the point mentioned above

Tested in
- Netbeans 6.0.1
- Java 1.6.03 and Java 1.6.04
- Ubuntu 7.10 (Gutsy) 
- Have mercurial plugins (may/may not be related)

Workaround
- Unplug the network cable
- Or disable the Network Interface in control panel

the funny things, that netbeans able to detect if the cable is unplugged or the network interface is disabled.

Why it is trouble, because under certain condition (dns server down, or network problem), Netbeans is unusable. Unless I
patience enough wait 10 min for timeout
Comment 1 David Simonek 2008-03-07 07:55:32 UTC
Thanks for inspection of this problem, passing to autoupdate, I think it tries to connect to get info about updates.
Feel free to reassign if i'm wrong.
Comment 2 Jiri Rechtacek 2008-03-07 08:10:10 UTC
Autoupdate does connecting to internet pure out of AWT thus cannot block any AWT operation. I'm sure it could make
trouble like this. I'm reassign back.
kiyut. please attach full stack traces while freezing open main window to allow us to complete problem evaluation. Thanks
Comment 3 Jiri Rechtacek 2008-03-07 08:39:04 UTC
Sorry for confusing, I wanted to say: I'm sure that AU _cannot_ make troubles like this. I'm sorry.
Comment 4 Lukas Hasik 2008-03-07 08:40:54 UTC
kiyut, we definitely need a tread dump when the IDE is frozen. Maybe even more thread dumps. If you are able to
reproduce it, go ahead, take thread dump - http://wiki.netbeans.org/GenerateThreadDump, and attach it here

thank you for your report
Comment 5 kiyut 2008-03-08 17:25:28 UTC
Created attachment 58025 [details]
Thread Dump
Comment 6 kiyut 2008-03-08 17:31:47 UTC
Just attached a thread dump.

Additional note:
This thread dump is generated under the following condition
- Netbeans 6.0.1
- Jdk 1.6.0_04
- Netbeans Settings: Under Menu - Tool - Plugins, I disable (un tick) all the Update Center available and set the Check
Interval to "never"

If it is Update Center problem, this is also indicate that Update Center does not honour the setting, because I untick
all the available Update Center and set the Update Interval to none, so it should not try to connect to Update Center.

The problem also exist whether the update center is enabled (ticked) or disabled.

To repeat the bug
- Just mess around with the DNS setting in the control panel eg: set the dns to non existant dns server, and make sure
it unable to resolve the address
Comment 7 kiyut 2008-03-08 17:40:26 UTC
Created attachment 58026 [details]
Another Thread Dump
Comment 8 kiyut 2008-03-10 09:13:46 UTC
Sorry, forget to mention to the condition (Thread Dump generated)

I have mercurial plugins installed and it is under Ubuntu 7.10 (Gutsy), which may or may not be related.
Comment 9 Lukas Hasik 2008-03-10 09:16:21 UTC
cc'ing mslama. I can see only registration in the thread dump.

kiyut, it is freezing only on start up, right? Could you check if there isn't other dialog hidden behind the main window? 
Reasigning to registration for evaluation

Comment 10 kiyut 2008-03-10 09:31:46 UTC
Yes, it is only freezing at startup only. After wait long enough, it will be normal again. And there is no other windows
/ dialog, it is only main windows. 

In relation with registration, I registered it sometimes ago when I installed Netbeans IDE and open the first time (I
guess), so It have not been popup again. And now during the freeze it is also not popup again, just main windows (but
freezing)
Comment 11 mslama 2008-03-10 14:21:20 UTC
Yes problem is in registration code. Network activity should be done out of AWT thread.
Comment 12 mslama 2008-03-13 15:32:05 UTC
Fixed in main trunk: efa685d71151. Most of work is now done out of AWT thread. Showing dialog is posted to AWT thread
using invokeLater. Additional fix: After opening browser using Help->Register registration status is not checked as this
is asynchronous anyway.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo