Bug 129027 - No code completion for partially typed p-namespace property names
No code completion for partially typed p-namespace property names
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Spring
6.x
All All
: P3 with 1 vote (vote)
: 7.3
Assigned To: Martin Fousek
issues@javaee
fix-in-67
:
Depends on: 129165 129272
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 15:43 UTC by Andrei Badea
Modified: 2016-07-07 08:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Badea 2008-03-03 15:43:17 UTC
Invoke the code completion for

<bean id="foo" | class="FooAbstractController"/>

The p-namespace property items pop up, among them, "p:cacheSeconds". But when I invoke the code completion for

<bean id="foo" p:cache| class="FooAbstractController"/>

I expect the "p:cacheSeconds" and "p:cacheSeconds-ref" items to pop up, which doesn't happen.
Comment 1 Andrei Badea 2008-03-04 16:38:09 UTC
This isn't a problem in the code completion, but in the XML infrastructure. Given

<bean id="foo" p:cache| class="FooAbstractController"/>

the XML lexer returns an error token starting at the class attribute. The corresponding Element doesn't contain a class
attribute, so the code completion can't resolve the bean class name. Filed issue 129165.

This would have low impact, since users usually put p-namespace properties after the class name. But, unfortunately, for

<bean id="foo" class="FooAbstractController" p: />
<bean id="bar" class="SomeOtherClass"/>

the attribute computation seems to "leak" into the bar bean, so the foo bean appears to have the SomeOtherClass class.
Comment 2 Andrei Badea 2008-03-05 13:18:05 UTC
Filed issue 129272 for the attribute computation. Hopefully it will be fixed for 6.1.
Comment 3 Jiri Prox 2008-04-11 01:20:21 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 4 Jayashri Visvanathan 2008-06-06 21:33:09 UTC
Andrei, Now that 129272 is fixed, can you close this ? 
Comment 5 Andrei Badea 2008-06-09 09:56:03 UTC
No, since issue 129165 still needs to be fixed. The original scenario is still reproducible.
Comment 6 nairsujit 2008-09-24 03:52:52 UTC
Target milestone revised to future in accordance with the milestone of its dependency issue # 129165. 
Comment 7 Erno Mononen 2010-10-13 11:20:42 UTC
Taking over Alexey's JSF and Spring issues.
Comment 8 Martin Fousek 2011-09-27 07:50:02 UTC
Issue #129165 is still valid and blocking this issue and I'm afraid that it will not be fixed in nb71 as well. Changing the target milestone to Next and let see what about XML issue then.
Comment 9 Martin Fousek 2012-11-06 08:49:50 UTC
Blocking issue #129165 still valid so I'm targeting this one to the next release.
Comment 10 Martin Balin 2016-07-07 08:56:06 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo