Bug 128348 - ConnectionWidgetLayout alignment constraints need to be more dynamic
ConnectionWidgetLayout alignment constraints need to be more dynamic
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Graph
3.x
All All
: P1 with 1 vote (vote)
: TBD
Assigned To: Trey Spiva
issues@platform
http://wiki.netbeans.org/GLConnection...
: API_REVIEW_FAST
: 121204 (view as bug list)
Depends on:
Blocks: 129477
  Show dependency treegraph
 
Reported: 2008-02-25 19:26 UTC by Trey Spiva
Modified: 2008-07-24 17:46 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trey Spiva 2008-02-25 19:26:55 UTC
Currently the layout constraints for ConnectionWidget is very static.  However this does not work well as the user moves a widget around the scene.  Therefore 
we need to add alignment constraints that will allow the layout manager to adjust the child widget correctly as the source and target widgets are moved 
around the screen.
Comment 1 Trey Spiva 2008-03-07 17:15:53 UTC
*** Issue 129477 has been marked as a duplicate of this issue. ***
Comment 2 Trey Spiva 2008-04-22 21:43:19 UTC
Please see the attached URL for a for in depth summary of the API Change.  The URL also contains links to the source file diffs.  However for connivence the 
diff links are:

http://hg.netbeans.org/uml-meteora/rev/d6d382432fa1 - Changes to the apichanges.xml file.
http://hg.netbeans.org/uml-meteora/rev/d8058ea09702 - Source file changes.
Comment 3 Trey Spiva 2008-05-12 19:30:29 UTC
I am going to merge this changes into the main repository.
Comment 4 Trey Spiva 2008-06-13 14:30:42 UTC
The change was added to the main repository.
Comment 5 Trey Spiva 2008-07-24 17:46:27 UTC
*** Issue 121204 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo