Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 127672 - Frozen delete project action
Frozen delete project action
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSP Parser
6.x
PC All
: P2 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@javaee
release601_fixes_candidate2, release6...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 17:27 UTC by Lukas Jungmann
Modified: 2008-03-20 18:54 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (18.27 KB, text/plain)
2008-02-18 17:29 UTC, Lukas Jungmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2008-02-18 17:27:46 UTC
-have a web project
-run delete action (including sources) on it

=> it stops at 38% with no way back nor forward, thread dump attached
Comment 1 Lukas Jungmann 2008-02-18 17:29:21 UTC
Created attachment 56828 [details]
thread dump
Comment 2 Tomas Mysik 2008-02-18 17:47:05 UTC
I'll look at it.
Comment 3 Tomas Mysik 2008-02-19 16:30:41 UTC
Fixed in http://hg.netbeans.org/main?cmd=changeset;node=4cffe70b2b73, please verify. Thanks.
Adding Jindra to CC - please verify as well, thanks.
Comment 4 Jindrich Sedek 2008-02-20 11:04:24 UTC
Fix works well from my point of view -> no deadlocks and I didn't face any problem is functionality during simple check,
Lukas should verify deadlock for sure
Comment 5 Lukas Jungmann 2008-02-26 17:07:35 UTC
cannot reproduce now => v.
Comment 6 rbalada 2008-03-07 18:10:39 UTC
I've backported this patch to release601_fixes branch as part of fix for issue 123370.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo