Bug 127216 - [65cat] REGRESSION: Bring back find by type
[65cat] REGRESSION: Bring back find by type
Status: RESOLVED WONTFIX
Product: utilities
Classification: Unclassified
Component: Search
6.x
All All
: P3 with 2 votes (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@utilities
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 16:24 UTC by misterm
Modified: 2013-09-04 15:53 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2008-02-12 16:24:38 UTC
When several xml files belong to a project, searching for a string using *.xml is a slow operation, especially when the
user knows the object types that matter to them and the search term can occur in several other xml types. The IDE used
to allow search based on file/object type. This feature should be brought back.
Comment 1 Marian Petras 2008-02-12 22:04:49 UTC
Replacement of a find dialogue with another find dialogue with many pros and a few cons is not a defect. I understand
your need but I will not track this as defect - I change the status to ENHANCEMENT.

For your information, the support for tabs in the Find dialogue has been maintained during redesign and reimplementation
of the dialogue. So it is enough to write a custom search type (extends org.openidex.SearchType) and put it to the
default lookup and then write a custom search type customizer (a Swing form implementing interface
java.beans.Customizer. Names of the SearchType class and the customizer class must have a common base (e.g.
TypeOfObject) and suffixes "Type" and "Customizer" (e.g. TypeOfObjectType, TypeOfObjectCustomizer). The Find dialogue
will recognize it and display a separate tab for it in the Find dialogue. You do not need to add the search type to the
Utilities module - it may be in a separate module.
Comment 2 Jaroslav Havlin 2013-09-04 15:53:06 UTC
The Search API has been redesigned, so the issue is now quite outdated.
API for custom search providers is now available instead of search types.
Closing this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo