Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 124934 - renaming a fragment does not update name in navigator
renaming a fragment does not update name in navigator
Status: RESOLVED WORKSFORME
Product: editor
Classification: Unclassified
Component: CSL (API & infrastructure)
6.x
All All
: P4 (vote)
: 7.0.1
Assigned To: Milutin Kristofic
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 06:19 UTC by pepeio
Modified: 2015-08-18 14:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pepeio 2008-01-09 06:19:40 UTC
Split from this report:
http://www.netbeans.org/issues/show_bug.cgi?id=122476
Comment 1 pepeio 2008-01-09 06:22:34 UTC
see description 9 in linked bug report for the description.
Comment 2 _ sandipchitale 2008-01-16 18:44:51 UTC
I am able to reproduce. Looks like the Page model is not getting refreshed after the refactoring.

The workaround is to hit refresh on the Designer toolbar.
Comment 3 _ sandipchitale 2008-03-26 17:12:23 UTC
This is happening not only for VW jsp pages but also for the simple .jsp file. The Navigator title does not seem to update.

Please note that when one select the node in Projects window for renaming - the navigator is showing the JSP xml
structure, not the VW Designer outline.
Comment 4 Marek Fukala 2008-08-21 15:35:25 UTC
The file name in the navigator is updated once you focus the document again. This is a generic GSF issue, IMHO really
marginal.
Comment 5 David Strupl 2009-01-14 14:35:49 UTC
Moving from ruby/GSF to editor/CSL. Step one: assign to myself ;-)
Comment 6 David Strupl 2009-01-14 14:43:59 UTC
Step 2: trying to make the owner not myself but the owner of the subcomponent.
Comment 7 David Strupl 2009-06-08 14:00:57 UTC
Marek, these are yours now ...
Comment 8 Milutin Kristofic 2015-08-18 14:33:44 UTC
I think this already works at current Netbeans versions.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo