Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 123928 - FileNotFoundException after trying to uninstall plugins
FileNotFoundException after trying to uninstall plugins
Status: VERIFIED DUPLICATE of bug 122186
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All Windows Vista
: P3 (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 08:58 UTC by novakm
Modified: 2008-01-03 07:12 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description novakm 2007-12-13 08:58:43 UTC
1) Deactivate any plugin and restart IDE
2) In plugin manager check that deactivated plugin and any other activated and push uninstall button
3) Push Uninstall button and then choose Restart IDE later
result: following FNFE is thrown:
java.io.FileNotFoundException: D:\install\6.0_200711261600\userdir\update\deactivate\to_uninstall.txt (Access is denied)
	at java.io.FileOutputStream.open(Native Method)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
	at org.netbeans.modules.autoupdate.services.Utilities.writeMarkedFilesToFile(Utilities.java:308)
	at org.netbeans.modules.autoupdate.services.Utilities.writeFileMarkedForDelete(Utilities.java:278)
        ...
If you look into the plugin manager, those two plugins are marked with the symbol meaning that it needs restart of IDE
to complete deactivation. However, if you restart IDE manually, those two plugins are in the same state as before - one
is activated and the other is not, the uninstall didn't work.
Note that if you would have chosen Restart now in step 3), it works as expected.

Product Version: NetBeans IDE 6.0 (Build 200711261600)
Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-b05
System: Windows Vista version 6.0 running on x86; Cp1252; en_GB (nb)
Comment 1 rmatous 2007-12-13 13:02:20 UTC

*** This issue has been marked as a duplicate of 122186 ***
Comment 2 novakm 2008-01-03 07:12:17 UTC
Verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo