Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 123592 - Text Editor looses focus when using Alt+Tab
Text Editor looses focus when using Alt+Tab
Status: RESOLVED DUPLICATE of bug 73960
Product: editor
Classification: Unclassified
Component: Navigation
6.x
All All
: P1 (vote)
: TBD
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 20:21 UTC by Jerry Waldorf
Modified: 2007-12-07 09:22 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jerry Waldorf 2007-12-06 20:21:07 UTC
When switching between applications using the Alt+Tab keys on Windows the focus moves from the text editor to the Menu.
 The user must then press the Alt key one more time to switch back to the text editor.  If they start typing right away
when back in the netBeans with the focus on the menu, the menu navigation kicks in and the user starts executing menu
commands.  If they are in the end of typing Javafx and type "f" "x" they will exit netbeans.  Or other actions that they
don't want.

I am constantly switching back and forth between documentation that is in the firefox and netBeans that I constantly run
into this issue.  Which is very frustrating.  I imagine that many other people need to code while reading through
documentation and therefore suffer the same problem.  See attachment for a video of this in action.
Comment 1 Miloslav Metelka 2007-12-07 09:09:09 UTC
I'm wondering whether there isn't any resident program causing this.
Do you use keyboard locale switching in Windows? (e.g. I could switch between US and Czech keyboards) If so do you
switch by Alt+Shift or another key combination?
Could you please attach the NetBeans log file? Thanks.
Comment 2 Jiri Prox 2007-12-07 09:22:03 UTC
Unfortunately  this is a JDK bug, see issue 73960

*** This issue has been marked as a duplicate of 73960 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo