Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 123587 - Disk space check should take into account user quota
Disk space check should take into account user quota
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: NBI
6.x
All Solaris
: P3 (vote)
: 6.x
Assigned To: dlipin
issues@installer
:
: 123389 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 18:56 UTC by dlipin
Modified: 2008-04-02 06:05 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
This is the log file of the netbeans installer when it fails (1.41 MB, text/plain)
2007-12-07 22:29 UTC, baher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dlipin 2007-12-06 18:56:48 UTC
Opening the issue as the replacement for 123389.

From Baher:
The installer fails on Sun Solaris with the following log file.. Same thing happened with me on (rc2) load.. but I had 
rc1 installed correctly
Comment 1 dlipin 2007-12-06 18:57:18 UTC
From Baher:

The home directory doesn't have enough space
Comment 2 dlipin 2007-12-06 18:57:44 UTC
Baher:
OK.. I have no problem to change the issue to invalid..
I'd like to address this issue somehow.. hence you are using the home directory as temp directory, you may need to 
check the diskspace on that directory and warn the user
That would give the user more information about the installer process
What do you think?!

Me:
Actually the installer checks the disk space at the directory where you want to install NetBeans/servers.
If the installation directory (or any of its roots) is a symlink then this check does not work well (see also http:// 
www.netbeans.org/issues/show_bug.cgi?id=122040, fixed in development builds).
What is the directory /home/omarb in terms of the filesystem?
Is this directory a symlink to any other ?
Is /home directory a symlink to any other directory?
Is /localdisk directory also a symlink to any other directory? 


Baher:
None of the directories in my home directory (/home/omarb) is a symbolic link.
The home directory is a mapped network location..
/localdisk is a mapped local harddisk


Me:
Let me ask some more questions...
You say that /home/omarb is the mapped network drive and if I am not mistaken there are about 44Gb of free space there.
The first error occurs during the data extraction to /home/omarb/.nbi directory.. is there any special quotes set to 
this mapped directory?
In other words, is it true that you (as a user) can use only part of that 44GB while "df" says that all 44GB are 
available?
If yes then.. I can`t say that I have the right answer or suggestion now. I don`t have an idea how the installer can 
check the real space that the user can use. Maybe do you have any idea on that?
Not sure that I understand you words about "/localdisk is a mapped local hardisk"...
As far as I see root (/) is mounted. Is /localdisk just a directory at / ? (at least, I don`t see /localdisk at the 
mount table, so making this assumption) 


Baher:
Yes.. you are correct.. I have a quota on my home directory.. It all makes sense now..
I use the /usr/sbin/quota to know my quota.. For Example,
Disk quotas for omarb (uid 4075):
Filesystem     usage  quota  limit    timeleft  files  quota  limit    timeleft
/home/omarb   943880      0 1577704              18992      0      0           
 
Can the installer use this info?!
I understand that this could be very tricky to do, I suggest to change the installer to warn the user that he has to 
have some enough diskspace on home directory or allow the user to use a different location to install these temp files, 
and make this very clear in the installation wizard
 
/localdisk is mounted to my harddisk, I couldn't find it as you said in the mount table.. but I know for sure it's my 
hard-disk ! :-)
Comment 3 dlipin 2007-12-06 18:58:10 UTC
*** Issue 123389 has been marked as a duplicate of this issue. ***
Comment 4 baher 2007-12-07 22:29:28 UTC
Created attachment 54018 [details]
This is the log file of the netbeans installer when it fails
Comment 5 dlipin 2008-03-14 13:52:51 UTC
Fixed.

http://hg.netbeans.org/main/rev/1df43684b2e4
http://hg.netbeans.org/main/rev/7b75661b423e

Baher,
please check the next build (>=200803150000)
http://bits.netbeans.org/download/trunk/nightly/latest/

Thanks,
Dmitry
Comment 6 dlipin 2008-04-02 06:05:30 UTC
part 3: http://hg.netbeans.org/main/rev/87bdeb78cd6a


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo