Bug 123436 - Code Templates
Code Templates
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Editor
6.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@php
issues@php
: PLAN
: 123461 (view as bug list)
Depends on:
Blocks: 123432
  Show dependency treegraph
 
Reported: 2007-12-05 11:03 UTC by Andrew Korostelev
Modified: 2008-08-12 12:25 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Korostelev 2007-12-05 11:03:26 UTC
a feature that lets to use an abbreviation instead of a short reusable piece of source code (code snippet). Each code
snippet has own predefined scenario of input that helps to adjust its code. Some of code snippets are also able to wrap
another piece of source code that is selected in the editor (see "Surround With..." action).
Comment 1 Andrew Korostelev 2007-12-05 16:44:44 UTC
*** Issue 123461 has been marked as a duplicate of this issue. ***
Comment 2 Vitezslav Stejskal 2008-04-18 09:03:25 UTC
There is around 20 code templates already available.
Comment 3 Mikhail Matveev 2008-08-12 12:25:47 UTC
Code templates are presented now


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo