Bug 123169 - groovy debugging support
groovy debugging support
Status: RESOLVED FIXED
Product: groovy
Classification: Unclassified
Component: Editor
6.x
All All
: P1 with 9 votes (vote)
: 6.x
Assigned To: Petr Hejl
issues@groovy
http://wiki.netbeans.org/wiki/view/Gr...
:
: 162865 166830 179807 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 17:12 UTC by schmidtm
Modified: 2012-11-14 21:30 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
patch (44.54 KB, text/plain)
2009-10-26 14:38 UTC, Petr Hejl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schmidtm 2007-11-30 17:12:53 UTC
This is a tough one: Developing the IDE Support to debug the execution of Groovy Sourcode.
Comment 1 owahlen 2009-04-14 21:10:36 UTC
I can imagine that this is very difficult and time consuming.
However I think it is a key feature to develop complex applications.
Wouldn't it make sense to work on this with higher priority?
Comment 2 Petr Hejl 2009-04-14 21:18:51 UTC
I agree. Increasing priority. On the other hand there is always a high level plan at the beginning of the release where
IZ priority is not the only criteria. In this terms this definitely has a high priority.

BTW You can debug grails app even these days (although not directly supported):
1) run grails-debug run-app from command line
2) choose Debug/Attach Debugger
3) configure you breakpoints
4) inspect local variables (groovy expressions not yet supported)
Comment 3 Petr Hejl 2009-10-26 14:37:19 UTC
Attaching the patch - to be applied post 6.8 (GroovyEvaluator is just placeholder now). Feel free to test.
Comment 4 Petr Hejl 2009-10-26 14:38:33 UTC
Created attachment 90085 [details]
patch
Comment 5 Petr Hejl 2009-10-26 14:40:04 UTC
*** Issue 162865 has been marked as a duplicate of this issue. ***
Comment 6 Petr Hejl 2009-10-26 14:46:09 UTC
*** Issue 166830 has been marked as a duplicate of this issue. ***
Comment 7 Petr Hejl 2009-11-30 08:31:33 UTC
Fixed in web-main f889ef0057dd.
Comment 8 mclaassen 2009-11-30 08:39:05 UTC
The target  milestone is 6.9?  Is this going to be in 6.8 now?
Comment 9 Petr Hejl 2009-11-30 12:41:07 UTC
No. It is going to be in dev build (trunk) and 6.9. There is a chance for this being in 6.8.1.

We are in feature freeze period for some time (see comment #3).
Comment 10 Quality Engineering 2009-12-01 03:03:04 UTC
Integrated into 'main-golden', will be available in build *200912010200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/f889ef0057dd
User: phejl@netbeans.org
Log: #123169 groovy debugging support
Comment 11 Petr Hejl 2010-02-02 03:20:37 UTC
*** Bug 179807 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo