Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 123049 - JSR172: Some complex classes are not generated
JSR172: Some complex classes are not generated
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Web Services
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Michal Skvor
issues@mobility
release60_fixes_candidate1, release60...
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 12:59 UTC by Lukas Hasik
Modified: 2007-12-12 16:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2007-11-29 12:59:47 UTC
Product Version: NetBeans IDE Dev (Build 200711160000)
Java: 1.5.0_12; Java HotSpot(TM) Client VM 1.5.0_12-b04
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)


this is regression caused by fix of issue 122096

-when there are complex types in wsdl it might happend that they are not generated
-it happend to me when the complex types were in arrays
-try to generate JSR172 Mbile client to following WS
# Stock Quotes WS - http://www.swanandmokashi.com/HomePage/WebServices/StockQuotes.asmx?WSDL
# Country Info WS - http://www.oorsprong.org/websamples.countryinfo/CountryInfoService.wso?WSDL
Comment 1 Marian Mirilovic 2007-11-29 14:32:28 UTC
It would be really nice to have a fix soon. So misk, please fix this issue into trunk as soon as possible. Thanks in
advance.
Comment 3 Lukas Hasik 2007-12-03 09:31:48 UTC
seems to be fine with the provided jars for testing
Comment 4 Michal Skvor 2007-12-03 10:51:02 UTC
Fixed:
Checking in WSDL2JavaImpl.java;
/cvs/mobility/end2end/jsr172/src/org/netbeans/modules/e2e/wsdl/wsdl2java/WSDL2JavaImpl.java,v  <--  WSDL2JavaImpl.java
new revision: 1.26; previous revision: 1.25
Comment 5 Lukas Hasik 2007-12-03 15:43:10 UTC
verified in trunk build #4671 from deadlock.netbeans.org

Product Version: NetBeans IDE Dev (Build 20071203113754)
Comment 6 pgebauer 2007-12-04 19:09:32 UTC
The fix has been ported into the release60_fixes branch.

Checking in WSDL2JavaImpl.java;
/cvs/mobility/end2end/jsr172/src/org/netbeans/modules/e2e/wsdl/wsdl2java/WSDL2JavaImpl.java,v  <--  WSDL2JavaImpl.java
new revision: 1.23.2.1.2.2; previous revision: 1.23.2.1.2.1
done
Comment 7 Lukas Hasik 2007-12-09 22:43:34 UTC
verified in 60-patch1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo