Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122902 - New page in new project won't go into design view until I switch to other view first
New page in new project won't go into design view until I switch to other vie...
Status: RESOLVED FIXED
Product: obsolete
Classification: Unclassified
Component: visualweb
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: _ sandipchitale
issues@obsolete
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 21:27 UTC by rdelaplante
Modified: 2008-03-26 16:57 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
visual web project (23.11 KB, application/x-compressed)
2007-11-28 18:17 UTC, rdelaplante
Details
message log from around that time (908.43 KB, text/plain)
2007-11-28 18:18 UTC, rdelaplante
Details
An other messages log (63.37 KB, text/plain)
2007-11-28 18:19 UTC, rdelaplante
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rdelaplante 2007-11-27 21:27:00 UTC
I created a new web project and added visual web jsf framework to it.  It opened the page1 and seemed to be stuck on
design view (grey, not white).  I was able to switch to JSP view and Java view, then when I came back to design view it
was white and ready to use.  I closed the page and opened again.  It was on design view, but it was all grey (no white
with text inviting me to add components onto the grid). I waited several minutes, still grey.  Switch to JSP view then
back to design view. Now it's ready to use.
Comment 1 rdelaplante 2007-11-27 21:27:25 UTC
I forgot to mention this is RC2 on XP Pro, JDK 6u3
Comment 2 Peter Zavadsky 2007-11-28 16:41:23 UTC
Hi, you say, it was gray but with the text inviting to add the components?
Wasn't there the "Loading, please wait.." message?
Also if you have, please, provide the log file.
Thanks.
For not I'll try to reproduce it. But I need more info.
Comment 3 Peter Zavadsky 2007-11-28 17:39:45 UTC
I was playing with it a bit but didn't reproduce it. Please provide more info, what was in the page, and the log file.
Thanks.
Comment 4 rdelaplante 2007-11-28 18:16:37 UTC
Yes like the grey "Loading, please wait..." screen, but without the text.  I remember the first time it said please wait
loading, then the text went away but the screen stayed grey. 

I will attach the web project and the last couple archived log files for you to peek at. Today I opened that screen and
this time it rendered the white design area with a grid for me to start using. 
Comment 5 rdelaplante 2007-11-28 18:17:21 UTC
Created attachment 53612 [details]
visual web project
Comment 6 rdelaplante 2007-11-28 18:18:21 UTC
Created attachment 53613 [details]
message log from around that time
Comment 7 rdelaplante 2007-11-28 18:19:50 UTC
Created attachment 53614 [details]
An other messages log
Comment 8 Peter Zavadsky 2007-11-28 18:48:24 UTC
The problem seems to be the OutOfMemoryError, which came when parsing the model. Passing to insync.
Please, if that happens again, try to bump up your the memory for your jvm, that is all you could do for now.
Also decreasing the priority.
Comment 9 _ sandipchitale 2007-11-28 19:40:52 UTC
The OOME happened in Insync code...but we need to tack down the original memory leaks that consume the memory.
Comment 10 _ wadechandler 2007-11-28 20:50:45 UTC
I think it is worth noting the priority should not be so low. I point to:
http://qa.netbeans.org/bugzilla/bug_priority_guidelines.html

Which states this to be a P1. Ryan has been using VWP for real work, and this is not only stopping him from using the
feature, but it is also making him have to restart the entire IDE. He has some files he might be able to now share with
a developer if that would help which might help track down the memory leak. He has some large files which he has
recently mentioned on nbusers which he can reliably reproduce the memory leak by using the visual editor if that will
help. He has created issue 123003 which might be the same thing, but he'll have to answer that.
Comment 11 John Baker 2007-11-28 21:17:07 UTC
It might help to see what's going on by generating a heap dump then attach to the issue, using jmap included
in Java 6
Comment 12 John Baker 2007-11-28 21:19:34 UTC
sorry, -please disregard, i forgot the size of the heap dump is too large to attach.

If you have a server that to ftp into to retrieve the file
Comment 13 _ sandipchitale 2007-11-28 22:44:21 UTC
At least with a single page project like the one you have attached I am not able to reproduce this issue. Had you opened
the other 30 page project prior to opening this project?
Comment 14 _ sandipchitale 2008-03-26 16:57:48 UTC
A lot of the issues related to memory consumption as well as performance has been fixed in 6.1.

As such I am not able to reproduce it for small or large project. Please reopen with a specific case if it happens again.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo