Bug 122484 - Javadoc integration with import management
Javadoc integration with import management
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Javadoc
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
plan61
: PLAN
: 100777 102012 117748 126102 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 12:12 UTC by Jan Pokorsky
Modified: 2008-03-27 15:39 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Pokorsky 2007-11-21 12:12:57 UTC
The javadoc support should be integrated to the import management. 

* Fix Imports should analyze also javadocs (@see, @link, ... tags)
* Unused imports should check references in javadocs
* The Add Import editor hint should be offered inside javadoc if necessary
Comment 1 Jan Pokorsky 2007-11-21 12:22:35 UTC
*** Issue 100777 has been marked as a duplicate of this issue. ***
Comment 2 Jan Pokorsky 2008-01-28 15:40:34 UTC
*** Issue 126102 has been marked as a duplicate of this issue. ***
Comment 3 Jan Pokorsky 2008-02-13 09:26:47 UTC
*** Issue 102012 has been marked as a duplicate of this issue. ***
Comment 4 Jesse Glick 2008-02-13 17:40:19 UTC
* imports used only in Javadoc should be displayed in black, not grey, text
* mark occurrences should ideally work also for Javadoc references
Comment 5 Jan Pokorsky 2008-03-24 21:28:51 UTC
I have added javadoc support of java references to following features:
 * fix all imports
 * unused imports highlighting
 * mark occurrences
 * instant rename of java references
 * hyperlinking
as http://hg.netbeans.org/main/rev/298c26505b10.

What is still missing is the Add Import editor hint. This will require more work. I have filed issue #130953 for it.
Comment 6 Jan Pokorsky 2008-03-27 15:39:55 UTC
*** Issue 117748 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo