Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122369 - Add possibility to define own source level for JSP pages
Add possibility to define own source level for JSP pages
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Web Freeform
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@javaee
issues@javaee
:
: 122365 122367 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 12:09 UTC by Tomas Mysik
Modified: 2016-07-07 08:56 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2007-11-20 12:09:46 UTC
Motivation for this enhancement can be found in issue #122200.

Web freeform should be able to define its own source level or somehow reference any existing compilation unit. Now, as 
can be seen in that issue, there's no possibility to define source level for JSP pages so then only currently active 
platform can be used for e.g. getting boot classpath (needed while editing JSP pages).
Comment 1 Tomas Mysik 2007-11-20 12:12:52 UTC
I forgot - of course, the default source level could be obtained from the project itself - see issue #122368.
Comment 2 Trey Spiva 2008-10-23 22:38:26 UTC
*** Issue 122365 has been marked as a duplicate of this issue. ***
Comment 3 Trey Spiva 2008-10-23 22:38:31 UTC
*** Issue 122367 has been marked as a duplicate of this issue. ***
Comment 4 Martin Balin 2016-07-07 08:56:26 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo